Перейти к основному содержанию

Model A2159, EMC 3301. A refresh of the entry-level 13" MacBook Pro. Available in Silver and Space Gray. Released July 2019.

81вопросов Показать все

Not charging when connected to power

Hi!

Recently my Mac has not been charging, even though it is plugged in.

I first noticed it behaving weird like this when I unplugged the charger and it showed that it was connected to power. I thought that was weird so I restarted it. But after that it did not take charge any more. The battery condition is shown as "Normal". I am also unable to update it (I am on Monterey 12.3) to 12.3.1 because it wants to be connected to power.

Block Image

I even ran Apple Diagnostics on it, much to my surprise it said the Mac had...no problems.

Block Image

I have tried these things:

  • An attempt at resetting the SMC
  • Many restarts
  • PRAM reset
  • Trying another charger
  • Booting into Safe Mode
  • Turning off battery management

When I tried to reset the SMC for my Mac it just booted up to the login screen even though I used the directions from Apple Support (they were for a T2 Mac, and my Mac has a T2 chip).

Is this USB - C board problem? A logic board problem? Battery? I really hope this is not a logic board issue, I have Xcode projects on it.

Any help would be appreciated!

Update (May 5):

Since the Mac was still under warranty, I sent it in to the repair shop. They said nothing was wrong with the computer (it powered on and charged for them) and sent me the computer with a new charger. However, when the computer was having the issue I tried 2 different chargers with no success. So I got the computer back Tuesday (May 3) and it has worked perfectly. I wonder if draining the battery down to 0% somehow reset the SMC.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Выбранное решение

Ouch! This is likely a logic board issue! Did you try the other connector? To be sure you could unplug the USB connector from the logic board and carefully plug in a spare USB port assembly, did the battery charge then? Another test would be to get a USB-C power meter to plug in line with your power adapter to see what it tells you.

Apple finally realized they messed up taking the charging LED away when they went to USB-C for power. The MagSafe-3 brings it back!

To salvage your data you'll need a charged battery to connect in place of yours, then back up everything! Using the same technique you can just unplug your battery (not removing it) so you can carefully! Plug in the spare.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Thanks for replying! I have started backing up my data.

из

Добавить комментарий

Добавьте свой ответ

mrfunnypenguin будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 1

За последние 7 дней: 23

За последние 30 дней: 124

За всё время: 434