Перейти к основному содержанию

Debuting in 2002, the first generation Sorento was a traditional truck-based body-on-frame SUV.

11вопросов Показать все

Secondary cooling fan won't come on

Any ideas where to go what are the relays and fuses for the fan? I tested the fans and they work!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
1 Comment

Without service manuals (the best way to have precise information), second guessing by anyone can be slow and maybe costly. I suggest joining Kia forums where owners share info. Expert automotive shops are next and last are dealers. Reasonable subscription to alldata.diy or Mitchell will give you immediate online access to factory service manuals.

из

Добавить комментарий

1 ответ

Наиболее полезный ответ

Hi,

Here's an image showing the wiring of the cooling fans in a 2006 Kia Sorento. (you didn't state the year model) and also the engine compartment fuse block layout.

There is a 30A fuse - CFAN (2) which supplies power to the fan.

The power is fed via relay - CF/H, which is operated by the ECM.

Block Image

(click on image to enlarge).

Hopefully this is of some help.

Update (05/24/2022)

@Marco G.

The circuit should be the same for a 2003 model.

Did you check if the relays operated electrically as you only said that they "...seem to be in good condition..." so I'm not sure what you meant?

Check the other fuse mentioned in the wiring diagram (see image below).

Other than that it appears as though the ECM supplies an earth at A17 on the ECM (green/orange wire) which goes to terminal 16 on the fuse block to operate C/FAN(2) and CF/H relays.

You may have to prove that the wiring from the ECM to the fuse block is OK as well as from the fuse block to the fan. (I don't know where you tested the fan from)

If the other fuse is OK and the wiring is OK and the relays electrically operate then the problem is in the ECM

Block Image

(click on image to enlarge)

Был ли этот ответ полезен?

Оценка 1

1 Comment:

Is a 2003 kia sorento and I have checked both of the relays and fuse and they seem to be in good condition I have also check the fans by applying 12v and they work as well any othe suggestions or how do I check if that relay is getting the signal from the ecm. Thanks in advance.

из

Добавить комментарий

Добавьте свой ответ

Marco G. будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 9

За последние 30 дней: 39

За всё время: 197