Bootloop with only battery connected to motherboard

Hello. I have a Pixel 3a I gave to my son several months ago. I've worked on it several times recently, after the power switch got mushy and I thought it would be good to replace the battery. I've taken it apart several times, no issues ... until now.

Just yesterday I took it apart to replace the power switch and battery, only to find that the brand new, OEM battery I'd bought was bad (puffed up).

In the process, I somehow broke the fingerprint sensor cable, so now that's no longer attached to the motherboard.

After putting it all back together, I found I was stuck in an infinite bootloop (gets to the logo for maybe half a second, every other loop). Can't get into any rescue function. E.g., I can send a fastboot boot for TWRP, and it's in that state long enough to send (maybe 2 seconds), but then just bootloops again. I can't change the fastboot menu, either.

The most important thing is that it's like this even when only the battery (and screen) is connected to the motherboard - nothing else. It's always on, and always bootlooping.

I've confirmed the problem isn't with any attached part, including the battery or power switch (I've tried both my old and new parts in each case), and again, it's like this when it's just the bare motherboard with the battery attached.

Am I SOL, or does anyone have any suggestions for trying to resuscitate. Could having broken the fingerprint sensor have any role in this? Or, more to the point, does anything need to be connected to the motherboard other than the battery for it to work correctly?

Thanks for any ideas.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 2

21 Комментариев:

@jaschneider I would expect it to boot loop since it is most likely not passing its POST. Toss the old battery and all the old parts. Then start with a new battery and connect the fingerprint sensor. See if that stopped its looping


Thanks, @oldturkey03. My new battery is going back, since it's clearly not good (puffed sides). Even so, using it instead of the old one makes no difference. Also, as I said, I accidentally broke the fingerprint sensor cable, so don't have it attached at all. I'd have to drop another $7 or so to see if that even made a difference.

Really, if this shouldn't be happening with nothing besides the battery attached to the motherboard, then my suspicion is that the motherboard just went bad somehow. If it wouldn't pass POST without everything plugged in, then I guess I might try getting a new fingerprint sensor, then (and only then) another battery.


To be clear, before yesterday, it wasn't bootlooping with the old battery. I'd expect it should still be good enough to boot the phone. As it was, it was basically lasting all day (not necessarily 24 hours), with a fair amount of use.


@jaschneider. Yes, I figured but just the idea of a puffy battery is always disturbing. Obviously something has failed with it to let it go puffy to begin with. I prefer troubleshooting with a known well battery. Bad batteries can really negatively affect testing.


@oldturkey03, no, I think maybe you're confused. My original battery looks great. It's the new battery that's bad. I opened everything up, then opened the sealed bag with the new battery, and immediately decided to just put the phone back together with my original battery.

But along the way, even though I was trying to be very careful, I broke the fingerprint sensor cable. So I just pulled that out. This may be the problem, if what you're saying is true.

I also successfully installed a new switch cable, with a nice, snappy power and volume buttons. The original was working, but the power button had gotten stuck a few times, and wasn't clicking. At this point, I'm sure both of those parts are fine, but the new one works better.


Показать 16 больше комментариев

Добавить комментарий