Перейти к основному содержанию

Model A1419 / Late 2013 / 3.2 & 3.4 GHz Core i5 or 3.5 GHz Core i7 Processor, ID iMac14,2

Вопросов 343 Показать все

Slow Write Speed (2TB Crucial Bx500 SSD) No Matter What

Hello,

I have a late 2013 27" that I replaced the failing HDD with a new 2TB Crucial Bx500 SSD.

Write speeds are an abysmal 20-40MB/s no mattter what.

I have also replaced the SATA cable AND enabled Trim.

I have tried also formatting the drive to exFat and then back to APFS with a clean install of Catalina, and then migrated the data again with migration assistant.

Originally, I thought the drive or cable was bad, so I replaced both again.

The issue persists. Write speeds hover from 20-40 MB/s.

Thank you for your consideration and help. I will be sure to respond as promptly as possible.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 3
2 Комментариев

Nice profile Picture!

из

Thank you, Ben!

из

Добавить комментарий

Ответов (2)

Выбранное решение

UPDATED ANSWER

The issue is with the SSD's QLC NAND flash technology. Basically the write speed is because they switched from TLC to QLC. Had nothing to do with my hardware. More info here: https://allinfo.space/2021/08/17/crucial...

The Black Magic Disk Speed Test was showing slow write speeds because of the cache or whatever being full. We were giving it too much data to write in too short amount of time by running the speed test over more than a couple times.

@danj Just wanted to let you know what I have found!

Был ли этот ответ полезен?

Оценка 1

3 Комментариев:

Well the Samsung 870 QVO while being the same class of ssd, does not suffer the same issue. Actually I noticed that the BX500 is fast to fill up the first 2-300 gb of space and after that it becomes slow, and stays slow, even if I give it time to rest. As if the fast SLC cache meant to offload into the slow QLC nand, just keeps those first 300 gb, and never offloads it. So when your drive has more than 300gb, you are writing directly to QLC from there on.

The samsung QVO and probably most other drives, use the fast SLC to gather your data, and then offload it to the QLC, and you should be able to transfer a good amount of data before it slows down. THe BX500 does not do that unless its empty, I dont know if that is a design flaw or what. But I bought 2 of them and they act the same. I have 20 samsung qvo and none of them do that.

из

@nik93421 - there is also the heat issue! The larger the drive the denser the cells are and the Flash hits heat saturation it can’t write any faster with out overheating. This is a common issue across blade SSD’s.

из

I have 1TB crucial bx500 and the drive is like less than a quarter filled with data. My read speeds are fine but the write speeds are like waay too low hovering around 10MB/s to 15MB/s. It doesnt matter if it a big or small file. I only get 15MB/s max and task manager shows the ssd is being used full 100% usage

из

Добавить комментарий

"Bingo! Your OWC is acting as the cache drive which you pulled. Put the Apple drive back in and break the Fusion Drive set if you can. Some macOS’s don’t clear so you’ll need to backup and wipe the HDD to clear its linkage to the Apple drive.

You’ll want to setup the SSD as your boot drive to get the performance. Install the MacOS onto it and copy over your Apps to it as well." @danj said here.

Был ли этот ответ полезен?

Оценка 0

8 Комментариев:

Thank you for responding. Can you help me understand how this would apply to me? I am using just a 2.5” SSD without a PCIe drive.

из

@kellywilkins89 - Are you sure you didn’t buy a Fusion Drive system?

At this point would check your systems hardware configuration to make sure. Go to About This Mac under the Apple icon menu, then click on the System Report button to then check the NVMExpress section. Do you see an entry?

из

@danj

Hi Dan! Thanks for helping.

It says “this device doesn’t contain any NVMExpress devices…”

Also, I've noticed that the issue persists even when booting to the same drive via an external USB to SATA adapter

из

@kellywilkins89 - Sorry, I forgot this system uses a mSATA blade drive, go into the SATA listing. Do you see two drives?

If not I think you need to run the onboard diagnostics. Using a USB keyboard restart your system and press the D key to enter, did you get a error?

из

@danj

The SATA/SATA Express tab only shows the 1 device. The 2.5" 2TB which I installed.

This previously had a fusion, but I did what I always do and I plugged in the new 2.5" ssd in via USB and did an internet restore with a brand new OS, and then I migrated the data over.

Once the data successfully migrated, I removed both fusion drives and installed the 1 2.5" SSD inside.

Also, the diagnostics showed no issues.

I also tried with a different 2.5" SSD (PNY 1TB) just to see if the brand of drive was the issue, and the problem still persisted.

из

Показать 3 больше комментариев

Добавить комментарий

Добавьте свой ответ

Boy Named Kelly будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 2

За последние 7 дней: 31

За последние 30 дней: 193

За всё время: 4,264