Casio ladies LTP-1130 - The Z-clasp won't stay closed

Had this watch several years, no issues, then after removing hastily, then jostling around in coat pocket a couple of hours, Z-clasp wouldn't stay closed onto stainless steel parallel-link bracelet any more. (It's a plain clasp, no extra closures on top.) Don't think any very small pieces dropped off (?) as still looks like photos of this model on internet, but can't be 100% sure due to hurry at the time. Bracelet is correct size, not too tight (so not caused by that). Found YouTube video of similar clasp (on a men's Rolex), which recommended slightly bending middle section of the Z , which I tried. Wish I hadn't as that didn't solve it. Managed to bend back to (approx?) how it was (2 sections fitting together with no visible gap), but still doesn't click/grip. Clasp (and bracelet) not broken and otherwise in good condition, though maybe slightly worn due to age. (I've tried cleaning clasp with damp cloth just in case dust could be an issue. - No luck.) Tried contacting Casio , they just said send it in. But rather mend it myself if it's simple to do??

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий