Перейти к основному содержанию

Model M7572 / 400 or 500 MHz G3 processor

Вопросов 46 Показать все

NVEDIT Command not bringing up text edit file.

Hi,

I have my old PowerBook G3 that is unable to boot from its HDD or CD.

Not sure what is the problem, with it, the HDD can be read on my Linux computer through a USB dock, so it is working.

I also ran the Disk Utility in VM (installed Mac OS X) and it gave me success so the installed OS on it should be fine. I also double-checked under WIN10 with MACDRIVE 10/11 and it said nothing is wrong with it.

Now the computer has been sitting for around 10 years or so because the charge it came with back in 2002 died on me. So, now I bought a new one (apple-black) it is brand new, and surprisingly my battery that came with the machine is fully charged by this charger, and it can work without power from it fine. The button batteries inside also charged but will leave the machine on the charger for a few days having it plugged into the power outlet.

So, I got a new (brand new) 512MB RAM module and installed it into the lower slot but tried both the upper and lower with no effect on the boot.

The DVD super drive is detected in open firmware when I type to list devices, but it does not show up in the boot manager - when you use the option and power.

So, I wanted to see NVEDIT and it looks like runs the command but nothing happens, it does not bring up any file to look through it.

I tried the back reset and the three OF reset commands too, they worked fine but still can`t access the NVEDIT file.

Tried option + command + p +r and it reboots fine, but still nothing happens.

With the power and option held down, I see the blue screen with a refresh on the left and the arrow pointing to the right but no ROM or HDD option is present.

So, now I plan to keep the machine charged and wait for the button batteries to charge up fully and see maybe it will solve my issues. I tried unplugging it but nothing happened.

Update (06/03/24)

I found this official repair guide for the Powerbook G3 series maybe useful;

https://www.applerepairmanuals.com/the_m...

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 1
1 Комментарий

This is the manual for the PISMO only;

https://www.applerepairmanuals.com/the_m...

из

Добавить комментарий

Ответов (1)

Наиболее полезный ответ

I belive these old PowerBooks can misbehave if the PRAM battery is dead or weak. One thing worth trying would be to disconnect the PRAM battery and see if the bootup behavior changes. A weak PRAM battery can be worse than one that is dead entirely, the machine should also work with no PRAM battery. Another thing to try would be to attempt to boot via OpenFirmware commands, since the disks appear to be recognized.

The OpenFirmware command to boot off of a hard drive with a Mac OS installation will look something like this, try running this to see if it attempts to read the disk:

boot hd:,\System\Library\CoreServices\:tbxi

Был ли этот ответ полезен?

Оценка 2

1 Комментарий:

I did try and no changes were made to its state. However, I remember the last time I had it on also experienced the same issue, and then I left the machine on for days and once upon restart, it booted into OS. Not sure what the voltage should be on the PRAM battery - I know it is made up of 8 pcs of 3v batteries some in series and some in parallel. I would say maybe 12v which is strange because it is supposed to provide power for the chip on the board that keeps time and memory. It is a lot compared to today's mainboard batteries with their one-button battery installed.

I will try the command a little later on today. One, thing is for sure the HDD and the OS on it were installed using this computer and it worked fine 10-12 years ago, and even in Linux Mint I could see and read/open most of the files except the MacOS9 ones.

из

Добавить комментарий

Добавьте свой ответ

fodor tomi будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 0

За последние 7 дней: 2

За последние 30 дней: 8

За всё время: 42