Перейти к основному содержанию

This Nintendo DS Lite was released in 2006 as the successor to the Nintendo DS. Getting inside this device is simple, making for easy fixes.

272вопросов Показать все

The DS won't turn on. Green light flashes for a second.

Hello,

Again I have a question about a DS Lite. This time it has the problem that it won't turn on. The green powerlight flashes for a second or two though. When I remove the Wi-Fi module, and then turn it on, the green light stays green, but it still won't power on.

I think it might be the upper LCD screen, since I replaced that. I read in someone elses question that the cable wasn't plugged in all the way. How far should it go in?

I have big fingers, so I can't really put it in farther since I can't get grip on it...

Do you think the LCD is the problem indeed (makes sense ofcourse), or something else? I tried the fuses F1 and F2, both seem to be fine.

Thank you.

Johan

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 3
1 Comment

This is unfortunate, have you checked both the top along with the bottom "shells" of the DS? If you do need a new ribbon cable for the top to bottom displace, then there are some people on ebay with them. I can get a link if you cant find one.

из

Добавить комментарий

10 Ответов

Выбранное решение

This usually means that a ribbon cable is disconnected. I would open up the top part of the clam shell, and Check all the ribbon cable. Use some tweezers if needed since you have big fingers. BUT! Be careful, those ribbon cables are delicate, along with the fastener clips (the black clamp where you fasten down the cable). If the cables in the top shell are properly fastened and they aren't damaged, then you might have to check the cables going from the sister board (Top shell) to the main motherboard (bottom shell). Check for damage, and check to see if its properly fastened into the both the motherboard and sister-board. Hopefully you have a Tr-wing bit (or screwdriver) to get into the bottom part of the DS.

Был ли этот ответ полезен?

Оценка 6

2 Comments:

It's hard to tell if they're fastened properly or are damaged.. Looks fine to me. I disconnected al the ribbon cables and connected them again.

The green light stays the same, but the upper screen gives a white flash too...

из

mines similar I turn on the power and, the green light turns on for 1 or 2 seconds but the bottom screen flashes for half a second then the system turns off again, and i clueless on what the problem is.

из

Добавить комментарий

Removing the wifi card resulted in a positive response. Yes, the logic board will turn on. Fuses will only impact on charging the battery. I assume the L2/L4 inductors are fine because the system actually turns on.

The logic board powers and see that the wifi is installed. The next step is to power on the top and bottom lcds. If there is a disruption of power to any of the lcds, then it would cause the system to power on and immediately power off.

The issue has to do with the lcd ribbon cable (or connection). The ribbon cable can only in as much as it allows. When inserting, push in as far as it goes until the flared ends on each side of the flex cable touches the edges of the connector on the logic board. Make sure that you then lock the connector.

Over 80% of these issues are related to the top lcd. The top lcd has to be twisted around the hinge of the unit. This, over time, (assuming that the hinge is not broken and top half is loose) may cause a slight tear. Buy a replacement lcd and try connecting it to the logic board with the lower lcd. Turn it on and see if it works.

Был ли этот ответ полезен?

Оценка 3
Добавить комментарий

Hey, 3 years later I'm answering to get some clue about this issue. I have the exact same problem, and I didn't get to repare it. I also disconect the Wifi module and the green led light stays... in the end, all the same sympthoms.

Have you finally repaired it? I'll keep researching for some clues.

Был ли этот ответ полезен?

Оценка 1

1 Comment:

Hey, I've got this fixed. See my answer below.

из

Добавить комментарий

Another year later the same problem occurs.

It turned out that, for me, the top screen's ribbon cable was *slightly* loose. By 'slightly' I mean it was less than a milimeter from the furthest point. I suggest you reinsert all your ribbon cables.

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

Finally, after investigating this problem for a whole night, I’ve managed to get the box fixed. It turned out to be a problem of both screens’ back light circuits on the main board got burned. So no flash on any of them when turned on (symptoms: green light lit after turned on, brightens for 1 second, and turned off; can charge properly).

You need to check all those LEDA1/2 LEDC1/2 connections on the main board all the way to the screen connectors.

Refer to the following pictures. Make sure every color coded pins are connected to each other. If not, connect them with a cable from the pin next to the screen connector to the corresponding capacitor above start button.

Block Image

Block Image

Something like this works for me!

Block Image

Был ли этот ответ полезен?

Оценка 1

1 Comment:

Thank you :)

из

Добавить комментарий

OK. I have the exactly same problem. The thing is, I swapped both screen with another machine and all 4 are working fine. When the green light is on for the second, no screen flashes. Wifi module removed will make it stay green, but light green. Anyone ever got it fixed?

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

The inductor just straight up fell off my system, I'm so boned. Here we go, I've done work like this, but just on a larger scale

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I got a problem too, I bought this non-working ds lite which I was gonna use for parts, it doesn't turn on, its green LED turns on and it's charges fine, I got it turned on but made the mistake to turn off and never got it on ever since. I was wondering what it could be before opening and messing it up. Any clues.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I have got the same problem: Bought a broken DS lite where the top screen’s ribbon cable and the hinge was broken. Bought a new top screen and it didn’t turn on. When I put in the charger (which works fine on my woking DSlite) the orange light flashes, but only at the beginning of putting the charger in. By the time it is properly in there, the light will have already turned of.

I read about it on many forums and replaced my F2 fuse, the F1 Fuse has continuity, also tried the LEDA1/2 mehod. Nothing is getting the board to work.

The board has no water damage and I use two known goof screens and a known good battery for testing. What could it be?

Был ли этот ответ полезен?

Оценка 0

1 Comment:

Look at the ribbon cable up to the light like the cash register does with your $100 bills,is the easiest way to see if anything a broken,look at the screen with a black light to see if there's cracks

из

Добавить комментарий

I've got a similar problem. I bought an old Nintendo DS and I wanted to repair it. It turned on but randomly turned off. So I opened it, I cleaned all the contacts and I tried to assembly everything.

The problem is that now, when I turn on, the green light appears just for a few seconds and the screens are black.

How can I check if I broke some cables or the cables are wrongly connected?

I noticed that the flat cable of the top screen doesn't "close it" very well... It seems too "loose".

Any suggestion?

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Johan Hendriks будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 16

За последние 7 дней: 96

За последние 30 дней: 421

За всё время: 40,169