Перейти к основному содержанию

Disassembling DualShock 4 Motherboard Assembly

Выберете то, что вам нужно

  1. Disassembling DualShock 4 Motherboard Assembly, Controller: шаг 1, изображение 1 из 1
    • Using the Phillips #00 Screwdriver, remove the four 6.0 mm screws securing the rear cover to the controller.

    • Be careful loosening the screws, using the wrong sized screwdriver, or letting the screwdriver slip can permanently damage the screw heads, making removal extremely difficult.

    Yo usé un Phillips #000, ya que el #00 quedaba grande y podía dañar el tornillo.

    Adolfo Gomez Toledo - Ответить

    A plain #0 works way better for me

    Jennica Tapia - Ответить

    I agree with Jennica, it's a #0 screw

    Peeter - Ответить

    to re-torque these PH00 screw... i found 19Ncm to be about the max. (since 27Ncm was too much)

    Dreamcat 4 - Ответить

  2. Disassembling DualShock 4 Motherboard Assembly: шаг 2, изображение 1 из 3 Disassembling DualShock 4 Motherboard Assembly: шаг 2, изображение 2 из 3 Disassembling DualShock 4 Motherboard Assembly: шаг 2, изображение 3 из 3
    • Four fragile plastic clips hold the casing together. You can see their locations more clearly in this guide.

    • The clips help hold the seams together. If you break these clips, the controller will still work.

    • Beginning with the left handle:

    • Pinch the left handle of the controller to introduce an opening.

    • Wedge a plastic opening tool into the opening and slide it up towards the joystick.

    • Pull down on tool to pry open the casing.

    • Repeat these steps for the right handle.

    Shoulders are where L1/L2/R1/R2 are, not the %#*@ handles. Confusing instructions.

    foxhoundunit89 - Ответить

    Quick tip: Be VERY careful at this step not to dislodge the tiny spring attached to the L2/R2 buttons. While removing the cover, it's easy to pull off either L2/R2 button. Inadvertently pulling off either button will also remove the tiny spring as well. While not too difficult to reassemble, it's not obvious where the spring goes as the spring is almost completely hidden along the side of the button (on the inside).

    I just successfully completed analog stick replacements for two controllers. I completed the first repair without any trouble but managed to dislodge (and almost lose) the spring on the second time around. Needless to say, I spent some time trying to figure out where the spring is supposed to go (no photos of this anywhere). By sheer luck, I figured it out on my own. :)

    Good luck and take your time--especially the first time!

    Michael Whang - Ответить

    couldn't have posted pics for me? :D

    kimsballs -

    Golden tip but I would add a thing or two.

    Most probably both triggers R1&R2 will stay in lower half of the pad case with springs hanging there.

    You must take them of their lower case sockets before assembly and fit them bellow L1&L2

    When you feel click when fitting them and spring works like on normal assembled pad you're done.

    If thats not the case do not try to assemble lower casing half as triggers will not work properly.

    Simon -

    if you lost the springs unfortunately, the triggers would still work but it is harder to get to the precise digital press. In other words you will have hard time to create a light press than a hard press.

    meaningless -

    My controller broke

    Gary - Ответить

    So what I seem to see a lot of sources fail to mention with this model (and promptly break without noticing) are the two plastic tabs attached to the front shell on either side of the headphone jack ; in order to properly pry that section open, all you need to do is lightly push those plastic tabs in, and the section should open up easily. That seems to be one of the main things that prevent people from prying the shell open.

    The updated models have the tabs as well, but aren’t as stubborn considering the bars between the shoulder buttons on those are inside as opposed to being a part of the shell.

    Hope this helps, and feel free to discuss, especially if you’re more familiar with the issue than me.

    Rifter - Ответить

    Thank you so much for mentioning exactly where the internal tabs are located, I couldn't for the life of me get into the controller otherwise.

    I found using two thin plastic guitar picks, the kind that bend more freely, worked very well to shimmy into place on either side of the headphone jack and pop the tabs to get the device to open.

    I did break a small piece from one of the teeth on the back half of the shell that inserts into the tabs, but I believe this was accidentally done before I came across your comment and was prying with a spudger willy-nilly.

    Gently wiggling the front half of the shell containing the main portion of the electronics allowed me to release the triggers and open the controller the rest of the way.

    Fizzwidgy -

    Very helpful, Rifter. Thank you.

    I found this shell assembly surprisingly difficult to separate if you don’t want to break the hook/tabs (and I’m a mechanic, fwiw). There are two pairs of hooks, and none of them are near the “share” and “options” buttons as Step 3 suggests. Like Rifter mentioned, one pair is on either side of the headphone interface. The other is along the sides, right up near the L and R paddles.

    With whatever tool you’re using (bike-tire levers work for me), pry it under the outside base of one of the handles (not inside), lever the tool downward a bit (controller is right-side-up), and slide it forward toward the L/R paddle. That downward rotation should help ease the tab off the hook. For the headphone tabs, pushing inward on the two top-half joystick mounds will help ease those off of the hooks, but you have to push pretty hard.

    If you get them apart, you’ll then be able to gently wriggle the circuit ribbon connector off of the top-half pc board (don’t use a tool - you’ll break it).

    John Branum - Ответить

    Why is this guide about unlatching the plastic clips before forcing the halves apart, completely separate and just linked here? I missed it and now 3/4 of my plastic clips are broken. It should not be a separate guide, it should be in the main guide, it's only a couple pictures!

    retrorocket160 - Ответить

  3. Disassembling DualShock 4 Motherboard Assembly: шаг 3, изображение 1 из 3 Disassembling DualShock 4 Motherboard Assembly: шаг 3, изображение 2 из 3 Disassembling DualShock 4 Motherboard Assembly: шаг 3, изображение 3 из 3
    • Wedge a plastic opening tool into the case-splittings and pull down to crack open the casing near the following buttons:

    • Share button

    • Options button

    • Split the plastic covers of the controller apart, taking note that they will still be attached by circuit board ribbons.

    • Three small pieces are often released from the framework. To prevent loss, maintain a controlled work field.

    • 2 Trigger Springs

    • 1 Grey Reset Button Extension

    You can't just pull the casing halves apart. There is a plastic bar that is part of the casing and separates the L1 and R1 buttons from the L2 and R2 buttons. To get this loose, pull the casing outward perpendicular to the L and R buttons until you can slide the L2 and R2 buttons from behind the plastic bar.

    dzturbd - Ответить

    SO yesterday replaced the thumb stick on my controller, and now the R2 button is stuck, know any way to remedy this?

    ScootsMcgoots -

    I know you put a warning, but I lost the grey reset button extension. Any idea where to get a replacement part?

    miamiman77 - Ответить

    Hey, not even sure when you wrote this, but wanted to share my solution for this problem. I lost one of my reset button rubber pieces when I was doing a different repair, and found that a standard bamboo skewer is just about the perfect diameter to function as a replacement. Just cut it to the proper length and you should be able to get it in there and get your reset functionality back.

    tcbrekke -

    You don't really need it. A long paper clip will work fine.

    Ron Smith - Ответить

    I've removed and changed all buttons all seemed ok but now the options and share button don't work, as in when I pressed them down there is no longer a click (bounce) I'm certain it's back in the correct place and I don't think they can be put the wrong way up, does anyone have any advice please :)

    Rachel - Ответить

    My share button stopped 'clicking'. When I stripped the controller down I noticed a small copper coloured dimple on the motherboard was depressed instead of proud like the one for the options button. With bluetack I was able to pull it out but each time I tested it with my finger it clicked once and stayed depressed. I don't think there is a permanent solution to this as it's probably metal fatigue or similar so i put a tiny bit of blue tack overy the dimple so the plunger could push that bit further and hopefully pull it out each time. Seems to work as I reassemble the controller. Fingers crossed it holds out a while! I'd love to know if someone else had a different solution.

    The5HD -

    I had an extra part, and it wasn’t gray. Thank goodness for the picture of the black one. It’s rubbery. The small end should be inserted down towards the gold colored spot. It’s next to the word RESET on the mobo.

    J Coyote - Ответить

    When reassembling: If, like me, your R2/L2 buttons stayed with the bottom of the controller when you took it apart, it will be impossible to reassemble and get the tiny springs back in place.

    To remedy, remove the buttons, and attach them, with the springs correctly placed, to the top of the controller. There are two tiny grooves, one on the button, and one on the controller top, into which the spring fits.

    Jeff Human - Ответить

    Jeff, we owe you a six pack for this comment.

    James Goldie -

    Thank You!! The spring came out and I looked for a way to reinsert it. So I led a thread through its opening (so it couldn´t jump away), and compressed it with pliers. So it was easy to put it in.

    VauWeh -

    Jeff, you've been a wonderfully helpful Human. Thanks for the ingenious tip.

    Kris W -

    Thanks man i was struggling there

    Shut-_-Up -

    My controller broke

    Gary - Ответить

    Something is stopping me from opening it cause it cut both by splitting tools

    Josuke Higashikata - Ответить

    Mine was also really really resistant to being pried open. In the end, i did my best to loosen the entire gap at least once, then inserted along the middle bottom and used more force than i would have been comfortable with. The plastic on the edges is slightly shot now and it’s not as smooth a grip-feeling anymore, but it came apart fine and I didn’t break anything important. There is just a lot of surface for a friction fit like this and the joysticks keep pulling it back down, which in combination makes it really resilliant. In my case it also was exuberated by a minor soda spill along the right handle which ‘glued’ it together, and i imagine that can also happen just with use and ‘hand cheese’, especially on the outer edges. There is a lot of surface area to stick together there.

    Seleen Shadowpaw -

  4. Disassembling DualShock 4 Motherboard Assembly, Disassembling DualShock 4 Motherboard Assembly: шаг 4, изображение 1 из 1
    • Remove the single 6.0 mm Phillips screw found below the battery retainer with the Phillips #00 Screwdriver.

    • Do not forcefully loosen the screw, as it may amount to permanent damage of the threads, making removal impossible.

    Hello. I got a new graffiti controller (without hardware) and i wanted to switch my parts in the graffiti one. I have a PS4 Controller. Not a slim. But it seems like my motherboard screw is on the other side.. its on the right side of the motherboard and my graffiti is on the left.. what controller do i need to fix this?

    TheTechnoMan - Ответить

  5. Disassembling DualShock 4 Motherboard Assembly: шаг 5, изображение 1 из 2 Disassembling DualShock 4 Motherboard Assembly: шаг 5, изображение 2 из 2
    • Gently detach the touchpad ribbon connected to the motherboard using the blunt forceps. The touchpad ribbon is connected to the motherboard by a connector that flips to tighten and loosen. During reassembly, to reattach the ribbon, the plastic tray will need to be gently removed from the motherboard and the flip-lock flipped up.

    Be very careful when you detach the touchpad ribbon. You could disconnect the other end that is inside the touchpad. In fact I would recommend you use a plastic spudger to release the clips on the sides of the battery holder, and then lift the latch to the ZIF socket of the touchpad. If your touchpad is not working upon reassembly, then the other end of the ribbon cable my have came loose in the touchpad. Use a plastic opening tool to remove the back of the touchpad, and lift the brown latch of the ZIF socket and reinsert.

    Patrick - Ответить

    thanks for the advice

    TMC -

    currently doing this and have found the desoldering part the most difficult. i purchased a 40w solder on sale and attempted to remove with flux and wick to no avail. a buddy of mine tried with his station and no dice. at this point im thinking the contacts are lead? any advice?

    swammieslippyslappy -

    So the springs are annoying couldn't see were you talk about these as it's very fiddly to do the last step of putting it back together. Not just a reverse of taking it apart!

    Frank Theplank - Ответить

    I concur. The springs are the worst part of this job. It would be nice if someone edited this to add some tricks for reassembly.

    raysmalley -

    You just have to put the r2/l2 buttons on the top side. There's a space around that white rubber thing where you can just snap them in. So that you have all the shoulder buttons together before putting the 2 parts back together.

    Flow Von D -

    Tilt your controller and trigger so the triggers are pointing to the ground it stops the spring popping out so much place spring inside the trigger and clip on thats how i do it anyway :) the touchpad is my problem area replaced my stick covers and now it just doesnt work at all :(

    drwhatfunk -

    Thank you for this recommendation. Made disassembly SO much smoother.

    jeninholland02 - Ответить

    What I did for the Springs was place the spring on the button. Turned the button to where the spring is up on top then attached the button to the controller this helps keep the spring in place as you reattach it that is really the only trick that I found to it.

    Matthew Luna - Ответить

    “The touchpad ribbon is connected to the motherboard by a connector that flips to tighten and loosen” —> Just fixed a controller I bought in 2017. There was definitely no flip connector there, the ribbon simply went in. I guesss the internals changed. So beware: don’t mess with the female connector on the motherboard if there’s no obvious flip switch.

    jonl - Ответить

    Thank you. I just broke a piece of the plastic because it will not flip. I could not figure it out and was wondering if the version in these demonstrations was different than mine. Thank you for addressing this.

    nearthecross -

    never had spring problem

    DARKMATTER - Ответить

    Just want to say big thanks to ifixit for mentioning the flap. It worked like a charm. I searched high and low on all the usual forums, Reddit, Youtube, you name it. Who knew it was as simple as flipping the flap and no one even thought of mentioning it until I found this website.

    leehmclara - Ответить

    I don't see a flap for the ZIF connector on the controller (CUH-ZCT2U) I'm working on, so I gently pulled it out with pliers. I may not have seen it, but I couldn't see a release mechanism.

    Shane - Ответить

  6. Disassembling DualShock 4 Motherboard Assembly: шаг 6, изображение 1 из 2 Disassembling DualShock 4 Motherboard Assembly: шаг 6, изображение 2 из 2
    • Carefully dislodge the motherboard assembly from the front cover.

    • Vibration motors are loosely attached to the motherboard assembly. Provide support at the two ends to ease the separation.

    • When removing the motherboard assembly, try not to tilt the front cover upside down as the buttons and their covers may fall out.

    Yeah, the factory solder job for those motors on the mobo is terrible. Every time I open these up, I add more solder to those joints just to be safe.

    Robert - Ответить

  7. Disassembling DualShock 4 Motherboard Assembly, Disassembly Complete: шаг 7, изображение 1 из 3 Disassembling DualShock 4 Motherboard Assembly, Disassembly Complete: шаг 7, изображение 2 из 3 Disassembling DualShock 4 Motherboard Assembly, Disassembly Complete: шаг 7, изображение 3 из 3
    • Successful disassembly of the controller will result in the following three parts, respectively:

    • Motherboard Assembly

    • Front Cover

    • Rear Cover

    One day my R2 trigger refused to work all in a sudden. The second day it spread to my square button. I dissembled the controller to this step and found some liquid between the green motherboard and the black plastic holding it. I should not have bought a second-hand especially for a launch version. Anyways I cleaned it up and it still didn't work. I then went to ebay and bought a new motherboard. Basically it is a piece of delicate plastic like PCB. It is held in place by 3 plastic columns and 3 gaps for sliding underneath both triggers and the touch pad. Sorry for no pictures but a careful removal of the old one would give you the best illustration of how to put the new one back. First remove the rubber pads of the triggers, which allows you to slide in the PCB. Then there are another 2 small plastic columns at the back of the gap near the touch pad. There is no need to detach the rotors. A pair of tweezers would help greatly. My controller now works perfectly like new and thanks to the author.

    meaningless - Ответить


To reassemble your device, follow these instructions in reverse order.

142 участников успешно повторили данное руководство.

Maaz Hussaini

Участник с: 01/21/14

5 687 Репутация

Автор 3 руководств


Cal Poly, Team 6-21, Maness Winter 2014 Участник Cal Poly, Team 6-21, Maness Winter 2014


4 членов

Автор 43 руководств

20 Комментариев

So my controller decided to stop charging (still stayed on until the battery completely dained) a couple weeks ago so I bought a new charging port and ribbon and replaced it put it all back together just for it to work the same not charging but on so I figured maybe it was the battery all along but this time I took my other new controller apart so I could test the battery by connecting it to the new controller to see if it will take charge which they would take charge on the new controller but when I took the new ones and put it in the old on it still wouldn't take charge I have no Idea what else to do everything else works it just won't charge even the light is still on but if I keep it connected to a USB cable it will stay on since the battery was dead but the battery status remains the same.

Archie Roberta - Ответить

Same here except mine won't even work while plugged in. It just turns on and dies

Jonah Roeger -

there is a new and different version out (looks the same) different internals - anyone got one to show us? (Model = CUH-ZCT1E?)

Russ - Ответить

How do you put back the touchpad? That $@$* Is a &&^&^$^ paradox.

Modern Retro Gaming - Ответить

The top of the touchpad that has the groove has to be inserted at the part where the bottom of the touchpad is normally. Then you you move it up and you can wiggle it through the arc. After that it fits snugly like it supposed to.

Rick -

i too had this problem so i watched a video https://www.google.com/search?client=ope...

This saved my life on trynna put it together

Jake Owen -

Where does the grey reset button extension go?

Jean-Christophe Ouellet - Ответить

Once you reinstall the battery retaining tray with the 6m screw, you must slide the reset button extension “smaller side down” into the hole at the top right corner of the battery tray. (see pic on step 4, top right of black tray) Directly above the hole you should see the boxed in word <—[RESET] with an arrow. Line up the extension with the 2 groves in the trays hole; it should just drop in with easily with just the larger diameter half of the extension protruding above the edge of the tray. Keep an eye on it while you reassembly to make sure it stays in place. I hope this helps.

Steven Crellin -

same issue I have a jdm050 series CUH-ZCT12u series, pretty sure its a revision 4.

new battery, ribbons ,and charge port. shows it charging, I tested the battery with a loppo balancer, I also checked the pins on the main board where the battery plugs in and its correct. it works fine if im connected via usb or charging from a outlet. as soon as I unplug the usb cable it dies.

I up graded the whole thumbsticks with higher quality metal internals (zedlabs) and it worked fine for a few months. (I hadn’t been playing but maybe 3 hours a month. but I noticed the battery drain and short charge, I figured the battery was going bad. Well one day nothing, yellow pulse charging but battery wouldn’t charge.

I saw a video of someone having same issue and when they disconnected the ribbon for the pad, the battery would charge.

haven’t messed with that.

also my par ribbon doesn’t have a flap, it slides in a slot.

D Mcalonan - Ответить

My ribbon will not connect back to the rear end cover

Jxnah - Ответить

If you would like to watch a video on how to open your ps4 controller, here is one that could help you : https://youtu.be/9Chgw4sRTzs

Repair & Resell - Ответить

This is a lot better than most of the video on youtube which show you how to open the controller especially praying open the case. Most of the video cannot display clearly what’s under the casing. Good job!! I’d rather come here in the future looking for solutions

J Dior - Ответить

My ps4 controller won't turn but it will charge …..the other the buttons won't work I cleaned all the buttons when I managed to get a few of them working during a button set up in tekken 7 I realized that the x and o buttons were constantly pressed but i have cleand all the buttons and controller thoroughly

Cory Peters - Ответить

I only translate the tutorial, sorry but I cannot help you with this.

aristide nerot -

That sounds like corrosion. Did you spill soda over the buttons or anything? The flimsy plastic sheet boards like they use in here are really friggin succeptible to acid corrosion, citric accid does the job fine enough apparently. I killed my old cheap notebook in the same way back in the day. No cleaning on earth will help you once the ‘phantom signals’ appear i’m afraid.

Seleen Shadowpaw -

All in all a good instruction. However, mine came apart slightly differently (the l/r buttons for example are a single unit apparently and stay on themeselves, i also didn’t have to remove the flat cable that connects the touchpad). However, lifting the top shell off in the first step proved a lot more difficult and finnicky and i had to be more forceful than i would normally feel comfortable with. I also had to try really hard to get the touchpad back in place afterwards and only managed by again, using more force than i would have liked when re-inserting it. All in all it worked and i could clean the thing just fine, yay for non-sticking-buttons. However, i would reccomend at least putting in a note that the insides can slightly differ and that you sometimes have to be a bit more violent with the renitent top bit.

Seleen Shadowpaw - Ответить

yup this doesnt work at all, because there are several very different revisions out there, which i didnt expect and i just destroyed my controller completely following this "guide", thanks!

Albert - Ответить

You are not supposed to destroy it! The instructions are for DE C O N S T R UC T I O N

Johnny Goode -

Thanks for the excellent tutorial, it helped me get my nephew's controller to pristine condition.

Alex Lacount - Ответить

Добавить комментарий

Просмотр статистики:

За последние 24часов: 105

За последние 7 дней: 883

За последние 30 дней: 3,966

За всё время: 630,825