Перейти к основному содержанию

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

Вопросов 121 Показать все

PowerBook G4 17" 1.67 will not start up

Machine hung, then would not restart. Have read similar questions/answers, mine acts differently. On pressing "on" switch, speaker bongs normally. Fans and superdrive whir at first, but caps lock light will not come on when pressing caps lock kee.. After 30 seconds or so, superdrive stops. Small fans still running, but nothing on screen. Tried resetting PMU. No change. Will not eject CD by pressing touchpad when starting. Using 65W power supply, light on plug works normally, and battery is fully charged. Any suggestions will be appreciated.


Thanks, rdklinc. On your advice, I connected an external monitor. No signal. The CD was inserted AFTER the problem started (I thought maybe the CD had a system on it, and maybe could boot from that if the hard drive was bad), so I'm pretty sure the problem is not the CD. This machine has only a single 512K bank or RAM. I just tried re-seating it, and that didn't change anything.

The screen is completely black the whole time. Same results with and without the battery. Just tried the flashlight trick, and I'm not seeing any faint image. Same results holding the option key down while booting.

You speak of resetting the both PMU and the PRAM. What I have done is remove power and battery and hold (5 seconds) the power key then release. I've also done the shift-option-command-start press and release, and wait five seconds. I think either or both of these will reset the PMU. I've also pressed start and then (quickly) held down option-command-P-R. I'm not sure that is working, because I get only one "bong" tone, and I think it should give me at least two.

What seems so strange is that the caps lock light will not come on. Does that mean the PMU is not running? The little white light on the screen latch button does light as soon as the "on" button is pressed, but the caps lock light will not respond at all. Sure do hope this is not a video chip/logic board issue--logic boards are very expensive, I see.

Thanks so much for your help.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 3
1 Комментарий

well stated question +


Добавить комментарий

Ответов (3)

Выбранное решение

Hi! I'd remove the battery just to rule it out, and then reseat the RAM, and try one module at a time in one slot, and then the other, both to rule out each memory module, and also each memory slot. I would reset the PMU again with each RAM/slot configuration, and reset the PRAM each time as well.

Does the screen come on at all, or is it black the whole time? If it's black, do you see a faint Apple image when you shine a flashlight through the Apple symbol from the back? If so, this could either indicate a bad inverter cable, or a bad screen. Next I would connect the machine to an external display. If the external display works, you may have a dead screen, or the screen cabling may be failing. If it doesn't work, you may be experiencing a video chip issue, or a logic board issue.

The fact that it won't eject the CD is suspicious. What CD is in the drive? It's a longshot, but it could be that the CD is hanging the system. Try holding down the option key while powering on to boot into option mode, and see if the option menu pops up on the screen.

Let us know how all this goes, and we can go from there.


Был ли этот ответ полезен?

Оценка 3

3 Комментариев:

nice answer +


I would suspect a logic board issue but the OP could check the PRAM battery voltage with a multimeter to be sure that battery still works and make sure he use a 65 watt AC adapter.


Добавить комментарий

To Icesway: I am the original questioner. I wish I could give you better news. On my system the problem was traced to the motherboard itself. It was less expensive to buy a replacement on eBay than to purchase a new motherboard. So, now I have some "extra parts".

I hope your situation is not the same.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Just yesterday I solved a similar problem on this model PowerBook for a client.

After the startup chime the PowerBook would essentially appear to be dead, did all the steps above but nothing helped until I took out the RAM:, only one RAM stick worked, and in only one slot too, but this didn't solve the problem in its entirety.

After playing with the RAM I was able to start up in Open Firmware by holding the Command+Option+O+F keys down after the startup chime upon reboot, and reset the NVRAM by using the following commands (press return after each line, it will reboot after the last command is entered)




After doing the above the computer rebooted and I got the blinking folder with a ? as the computer searched for a system to boot from, okay- lets try booting in Safe Mode.

That didn't work and the computer went right back into Open Firmware, did this a couple times, so next time Open Firmware was up I typed in mac-boot

but pressed the Option key immediately after pressing the enter key in Open Firmware, this brought up the screen to choose a startup folder/disc, but it didn't show anything, so I connected an external startup drive which wouldn't show up either (I rebooted as above a couple times and it wouldn't recognize any drive connected).

Okay... so after a little googling around I found that perhaps the Airport card was causing a problem.

I took the case apart, unplugged the Airport card from the logic board, put the case back together, crossed my fingers, pressed the start button, heard the chime.... and the PowerBook started up like nothing had ever been wrong.

So there you have it, in my case (besides the RAM) the problem was a bad Airport Extreme card. I currently have the ribbon cable for it plugged back into the logic board, and it still boots, but with no Airport card recognized.

If the client wants an Airport card put in I'll take it apart further, put it in, and see if it works with one on Monday.

I hope this helps you, or someone else down the road.

A note however, the one RAM slot still doesn't work, and I seem to recall there was an issue with a PowerBook not sure which model, where a problem would arise in which there was insufficient power going to the RAM slots.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Gene Hite будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 0

За последние 7 дней: 6

За последние 30 дней: 17

За всё время: 11,376