Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Запчасти и инструменты

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

276вопросов Показать все

LED #1 blinks when connected. iMac not turning on

Hi. I have a late 2012 iMac 27 inch. This morning I tried to turn it on and nothing happened. I removed the screen to see what's going on. On the logic board, I can see that 1 LED is blinking. When I press the power button the LED resets the blinking but it never stops. I've been looking everywhere to determine what this blinking LED mean. PD. It is the only LED on, the other 3 of them are off. Thanks

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 2

Комментарии:

Did you ever figure this one out? I have similar issue. Thanks!

из

I have similar issue. =(

из

There is somebody who could fix this up?? Any help on this issue? Please. New power supply is not the problem.

из

Добавить комментарий

Наборы переключателей Nintendo

A quick fix to get back in the game

Shop Switch Kits

Наборы переключателей Nintendo

A quick fix to get back in the game

Shop Switch Kits

3 Ответов

Выбранное решение

Well it's a bad power supply. But not really that bad. It can probably be fixed with just a little work over with a soldering iron. It's late and I'm going to bed but Google "cold solders" and how to fix them.

UPDATE 3/16/16

https://learn.adafruit.com/adafruit-guid...

https://www.youtube.com/watch?v=h5_dBMuJ...

Был ли этот ответ полезен?

Оценка 3

Комментарии:

Thank you so much! I'll be trying to find some information about cold solders. Hope to find something. Can this be tested with a electronic tester? Thanks again!

из

I just installed a new power supply! And guess what? The blinking Led 1 Still there... So the blinking led means something else that we could not find clear information

из

there is shorting of some sort on the board its called cpu v sense I have the same ISSUE ON 820-00291 2015 27 INCH IMAC check with a magnifier for blown out components rusted tracks

из

if you remove the cpu the blinking light first led will be solid stable

из

Добавить комментарий

If there’s an LED coming on, then the power supply works - at least, well enough to power the LED.

An LED coming on (and maybe blinking) is a code for a variety of RAM/BootROM errors. Apple used to have a support note on this, but I don’t seem to be able to find it now. However, the University of Oregon has a reference:

https://it.uoregon.edu/node/3308

UofO’s list of blink error codes matches my memory, and is as follows:

  • Black screen, power LED on (solid): POST or BootROM failure
  • Flashing power LED once per second: bad RAM or no RAM
  • Three flashes, a pause, and three more flashes (occurs continuously): marginal RAM

If the LED is blinking, I’d try replacing the RAM. If you have no compatible replacement RAM, at least remove the RAM you have, clean off the contacts on the RAM sticks with a pink rubber eraser so they’re shiny, scrub out the RAM sockets with a soft dry toothbrush to get any gunk out of them, and try booting with the cleaned/reinstalled sticks.

It’s possible that one stick may have gone bad, while the others are still OK. Although installing in pairs is preferred for this generation, you can try each stick individually to isolate any stick that may have failed, and replace only the filed ones.

In the event that any of the followup commenters have a solid LED, the only way to repair the Boot ROM is to reinstall the operating system. You may need to reformat the internal drive as well, if the drive blocks where the old Boot ROM are physically damaged.

Your best bet is to boot from an external drive (hard drive or flash drive) with Disk Utility and an appropriate OS installer. Use Disk Utility to repair the internal drive first, then see if you can restart. If not, then try to reinstall the current OS. That will replace your damaged system software without altering your user account.

If that doesn’t work, then the safest thing is to boot from an external boot drive, clone your internal drive to a second external drive (using Carbon Copy Cloner or SuperDuper!), then erase (or reformat) the internal drive using Disk Utility, reinstall the operating system, and restore your applications/user accounts from your clone or from your last trustworthy Time Machine backup.

If you have a reliable and reasonably speedy broadband connection, it’s possible to boot your computer from an online Recovery Disk using keyboard shortcuts, and do repairs/OS reinstalls even if you don’t have an external boot drive. Different OSes can be reinstalled by different methods, depending on what OSes you’ve used before.

https://support.apple.com/en-us/HT201255

https://support.apple.com/en-us/HT204904

Был ли этот ответ полезен?

Оценка 1

Комментарии:

LED 1 should come on and stay on till the ON button is pushed, the power then goes to the RAM, logic board etc. after that, nothing to do with these parts only the power supply. Download and read the Service Manual.

из

Also, my 2010 27 iMac has a flashing led 1 until I press the on button then LED 1 and LED 2 stay lit and it starts up but no backlit on the screen, I have been using an external monitor for about 3 years now and that works fine. I have placed a small mirror on the base below the lights next to the ram panel and I see this behavior every single time I start up. Whats funny is if I don't press the on button when the LED 1 is in the lit stage it will not start. Then when the third LED lights up the external monitor gets its picture and all is well. Hope this helps some people.

из

Bad ram or no ram have audible beeps (look it up) or are usually just not recognized if you have good ram installed that it can start with. Boot Rom and other such problems usually end up with a kernel panic.

из

"Quote" "Bootrom (or Boot ROM) is a small piece of mask ROM or write-protected flash embedded inside the processor chip. It contains the very first code which is executed by the processor on power-on or reset." In this case, It does not reside on the Hard Drive. The hard drive has its own Boot Rom as has absolutely everything else with a chip on a board ie; everything else electronic. The chips have to "Talk" to each other for success of operation. Hope this clears up some confusion on the matter

из

Добавить комментарий

Maybe it's the processor, but I could not test it because it was old ...

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

manuelt637 будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 9

За последние 7 дней: 25

За последние 30 дней: 108

За всё время: 1,121