Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

Released on October 23, 2012. Core i5 or Core i7 Processor. Apple Fusion Drive.

227вопросов Показать все

OWC SSD sandforce 200026BB

I have a late 2012 Mac mini that came with 8 GB RAM & 500 GB HD. I added a OWC 120 GB SSD (Mercury Elektra) for the OS and Apps.

Everything was fine for a couple of years, so the other morning I turned it on and all I got was a folder with the question mark! I did a bunch of tests, in the recovery mode under Disk Utility the drive shows: 33kb sand force 200026BB

So my question here is: Is the SSD dead? And can I recover anything from it?

Update (10/14/2016)

Well, I contacted OWC and they offered to replace the SSD!

So for one part I appreciate their service and I have a new SSD, and for the other part I didn't recover my data, luckily it wasn't all that important.

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 1

Комментарии:

same. Bummer.

из

Добавить комментарий

2 Ответов

Выбранное решение

Sadly, the SSD maybe gone.

I would recommend you contact OWC to see if they have any ideas on recovering your drive. They may have a SSD firmware update which might fix things, otherwise you'll need to get a new drive (they may cover it under warranty).

Hopefully you have a good backup of anything important. If not, to recover any files if you can you'll need to first have a bootable system and then a means to connect the SSD independently to it.

I would put in a spare drive replacing the SSD, then use something like this: Startech 2.5" SATA to USB adapter to connect the SSD when I was ready to try to recover the files from it. That way I could get the system up and running using OS recovery services. Or, I would plug in a bootable external drive (Thunderbolt, FireWire or USB) that I already have setup as a bootable drive (A 16 GB USB thumb drive will work as well). If you have access to a second Mac system you could create that following this Apple T/N: How to install OS X on an external drive connected to your Mac.

Then using a good file recovery app like: Prosoft - Data Rescue installed on the spare internal drive I put in or the external drive boot drive to see if I could recover anything important on the SSD.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

I did what you suggested and tried a couple of recovery software but sadly I couldn't recover any files, so I contacted owc and they offered to replace the ssd, luckily I didn't lose any important work (that I recall)

из

Добавить комментарий

I know this is from years ago but I have been working on this recently and finally solved the issue, bringing my SSD back to life.

Let’s start by defining the issue: it is a common problem with old SSDs using SandForce controllers. Because of incorrect instruction management, these occasionally freeze up and deny system detection. The only thing that you may see if a ~30kb drive named SandForce{200026BB} , either in the BIOS or in the System Report.

What you have to do in order to solve it is pretty lengthy and complex, and you will not be able to save the files you have on your SSDs: it will all be gone. Having this in mind, I wouldn’t personally proceed unless you are very eager to bring your SSD back to life as a new drive.

Before starting this procedure, you can always try to forcefully issue some SATA wakeup commands to the SSD, by plugging it in a PC (You need a BIOS) and performing the following steps:

  1. Leave everything shut down for 2 minutes
  2. Boot and head straight to the BIOS, where you should see your device as SandForce{200026BB}
  3. Just wait on the BIOS screen for ~5 minutes
  4. Shut down and wait some more 2 minutes

I have tried the above multiple times, it was not helpful so I had to reflash the SSD controller. In your case it might work, so it is preferrable to try it before destroying the contents of your drive irriversibly.

If you are still willing to proceed, then, you will need to work on Linux (Fedora 32bits). The procedure consists in determining, retrieving and lastly correctly flashing a compatible firmware onto your SSD’s controller. As mentioned, it is a very lengthy procedure, and not very well documented at all. This guide describes the steps in English.

Make sure that you operate the 32bits version of Fedora, and that you also have a free SATA port. USB adapters will not work and the proceduere won’t work on Fedora versions other than 14.0 32bits.

Был ли этот ответ полезен?

Оценка 0

Комментарии:

As OWC stood by their product giving memitosh a new drive I'm sure he's set.

But you never know someone else might find this helpful!

из

You're right. Thanks Dan, I really hope my answer can help somebody in need of the same as I've been spending a good couple of days trying to unbrick my SSD.

Cheers and take care!

из

Добавить комментарий

Добавьте свой ответ

memitosh будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 3

За последние 7 дней: 23

За последние 30 дней: 77

За всё время: 3,294