Maps apps not getting directions

It seems, when using Cellular Data, Maps does not give me directions for any specified destination. It does, however, work for a few minutes after restarting the phone, and then it stops working again. It also works flawlessly when using Wi-Fi connection.

When it doesn't work, it just shows the loading icon for a few minutes and eventually says it couldn't connect(or something).

Have tried:

Using other map applications.

Updating phone.

Replacing the two interconnect cables (or however they're called) .

Turning on Wi-Fi with no connection.

All to no avail.

Possibly worth noting:

One time after replacing the rear camera the battery meter stopped working and the phone began to restart by itself(occasionally) if it was used immediately upon being turning on (No idea how this went down considering how smooth the replacement was. Will be damned if anyone finds a solution).

Compass does not work(also for whatever *!&*^#% reason(not the screen panel screws)).

Do not know if maps or compass worked properly prior to this replacement.

Help is definitely appreciated. Will be glad to provide more information.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0

2 Комментариев:

What iOS are you running? Also have you gotten your phone wet or dropped it hard?


Seems to be running 8.4.1. Haven't gotten it wet nor dropped hard, though then again I don't know if this hasn't happened to the phone before as it didn't come to me first hand. I don't think it's been wet, but when I first had it there were tiny wooden pieces spread out inside the phone and some dust stuck between the screen's glass and the digitizer. The rear camera also had dust spots in every photograph it took (which turned out to be uncleanable, hence the replacement) and the in-ear speaker didn't work(if any of this matters).


Добавить комментарий