Перейти к основному содержанию

Model A1001 or A1025 / 667, 800, 867, or 1.0 GHz G4 processor

Вопросов 50 Показать все

Startup stalls at Apple Logo

Powerbook was given to me by a friend as it displayed no video. I reseated the video cord and voila: os X 10.3 desktop! BUT the upper case was damaged and the trackpad non-responsive, so I replaced the upper case per instructions found here (thanks!)

After replacing the upper case, I left the battery out, and charged it overnight to make certain that the PRAM battery was charged. Machine booted fine, and I proceeded to do a clean install. I did a verify, found errors, attempted a repair and was informed DU could not repair the disk. I erased the disk instead, and verified. Told OK.

Installed 10.4 from system disk. Installation proceeded smoothly, but upon restart, all stalled at apple logo (gray apple, gray background).

No Peripheral devices.

Since then, I have tried

1. Swap Memory - no memory difference.

2. Reset the NVRAM/PRAM - no difference.

3. Safe Boot - did not respond to command

4. Verbose - did not respond to command

5. Start-up from os 9 or 10.3 won't respond to C command at startup.

6. Start-up from Data Rescue allows view of drive. Scan indicates 2000 ms seek times at several points.

7. Start-up from os 10.4. Profiler shows full RAM installed, POST last run 4/1/76 (sic) passed. Software Extensions does show Dependency Errors on IOAudioFamily for .iokit.IOUSBFamily, and .kernal.iokit. Airport card was not found. Disk passed verification. Repaired permissions w/o fault. Selected HD as start-up disk, shut down.

8. Removed Airport card.

9. Restarted. Ejected install disk.

Gray apple.

I don't have another Hard drive to swap, and am hesitant to invest in another in order to test faulty HD as hypothesis.

All suggestions are welcome!

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 3
Добавить комментарий

Ответов (3)

Выбранное решение

First thing I would do is to reformat the drive with the (write zeros option). This will map out any bad blocks you might have. Then reinstall a system.

If the machine will start from the optical drive with the Data rescue disk then it should start from a Retail system disk or the original system disk. Gray system disks made for other machines will not work. Please tell me about the disks you are trying to use.

You can also access the disk via another Mac in Target mode.

Charging the machine will not recharge the PRAM battery

Был ли этот ответ полезен?

Оценка 3

11 Комментариев:

Writing zeros as I type.

System disks being used are all retail Apple System disks. (Any idea why it won't recognize the 9 or 10.2, but does Data Rescue and 10.4?)

As for "charging the PRAM battery", I found that either here or on the apple support community. No one shot it down, so I tried it.



OK.... apparently can't write zeros. got about 18% of the way across the bar, and hung at 25 minutes remaining 18g drive) nothing but clicks.


Odd. S.M.A.R.T. status shows verified.


Okay, well after hanging at "25 minutes remaining" for an hour, it busted through and finished.

Installing 10.4 from retail system disk as I type.


Looks like you do have bad blocks. With it hanging like it did, I have serious doubts as to just how long this drive will last. You may have other problems, I'm concerned about the non-boot from 9 and 10.2 retail disks. First I would replace the IDE/ATA hard drive, install a system and then see if other problems present themselves.

Here's the type of drive you need: [связанный продукт отсутствует или отключен: IF107-008]

Here's how to install it: PowerBook G4 Titanium DVI Hard Drive Replacement


Показать 6 больше комментариев

Добавить комментарий

You might want to try removing the drive. It's not typical for hard drives to alter the behavior of the computer as far as lower-level functions, but it's not unheard of, so I'd remove it and see if that improves your ability to boot from CD, etc.

Also, sometimes machines that are stubborn about booting from CD, etc., have open firmware passwords enabled, i.e. they have been set up to prohibit you from finding a way to overwrite the OS. It's probably not the case, but I'd reset it anyway by changing the amount of RAM, and immediately resetting PRAM four times (the initial chime, plus keep holding down for three more chimes). It couldn't hurt.

Besides that, you may need to get another drive in order to further your testing. If you have a FireWire cable and another PPC Mac, you can put that Mac in target mode and boot your PowerBook from that Mac's hard drive in option mode...if this works and the PowerBook behaves itself, it's evidence that the PowerBook is basically good and the drive is the problem. If it doesn't work, that may point to the PowerBook's board being flaky (as a lot of Titaniums are at this point, unfortunately).

Good luck! Great question and analysis, by the way! +1!

Был ли этот ответ полезен?

Оценка 3

2 Комментариев:

Thanks. I routinely rebuild macs for a local thrift store. This is something I haven't encountered before.

Did manage to wrte zeros to the drive. Installing new system as I type.


New Drive it is! Thanks for your help!


Добавить комментарий

Condensed answer: replaced the drive, and all is well with the world.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

Thats great--now if you would please accept one of the answers to close the question. Thanks


Добавить комментарий

Добавьте свой ответ

brmilton будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 0

За последние 7 дней: 1

За последние 30 дней: 12

За всё время: 3,228