Why aren't any of my wireless mice working with my laptop?

I have a Asus X553M that I've had for about 3-4 years. The other day I found that my wireless mouse wasn't working. Changed the battery : nothing. So, I went and tried some of my other wireless mice (same brand, one older, one brand new). Still nothing. The mousepad and touchscreen work, but i preferto use a wireless mouse most of the time. Any ideas?

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

по рейтингу 0
Добавить комментарий
Spread Fixmas Cheer
Получите $12 за покупку от $50 и выше с промокодом FIXMAS12
Spread Fixmas Cheer
Получите $12 за покупку от $50 и выше с промокодом FIXMAS12

1 Ответ

Выбранное решение

Hi @kitkat21996 ,

Are you using a wireless mouse with a USB dongle or a Bluetooth mouse?

If using the one with a dongle, is the dongle the correct one for the mouse and is it showing that it is powered on when plugged into the USB port?

If you are using a Bluetooth mouse and if you have Win 10 installed (you didn't specify), check in Device Manager on the status of the Bluetooth Network Adapter. (quick way to Device Manager is to right click on the Windows Start button - left side of Taskbar, and then click on the Device Manager link that appears in the options box).

If there is a red cross next to the Bluetooth entry, right click on the entry and select enable this device and see if the BT mouse then works.

If there is a yellow exclamation mark next to the BT entry, right click on the entry and select Properties > Update Driver .

This is where you can update the drivers to see if this resolves the problem

Here is a link to the latest Asus Win 10 drivers for your laptop. Download the drivers relevant to your particular BT adapter, (see Device Manager listing for make and model info).

See the Note near the top of the webpage regarding installation of the drivers.

Был ли этот ответ полезен?

по рейтингу 2

Комментарии:

The ones I have use a USB dongle. No matter which one I use, they all turn on and show green lights. In the Control Panel, under Devices and Printers, it recognizes it there, but the pointer just doesn't move. Today I went and got a new one that has a USB cable and that one didn't work either.

And, yes, I do have Windows 10. Sorry for not mentioning that.

And all of my mouse are Logitechs if that matters any.

от

Hi @kitkat21996 ,

With a mouse connected Go to Device Manager > Mice and other pointing devices > click on + symbol to expand, right click on USB mouse entry and select uninstall.

Restart the computer in the normal manner, wait till it boots fully to the desktop and then connect the mouse again, Windows should locate "new" hardware and install it, and check if it now works OK

от

I went and did as you suggested, but under Mice and other pointing devices, it only says ASUS Touchpad. I've always had issues with the two USB drives, though, so I'm almost sure there's a communication issue. But i plan on getting a new pc here soon so i may just not worry about it. Thank you, though.

от

Hi @kitkat21996 ,

Go to Device Manager and uninstall the USB Host Controllers and then restart the laptop. (make sure that there are no USB ports in use)

When laptop has found 'new' hardware insert mouse or wireless dongle and check if it now works.

от

Okay, I went and did that and it re-installed the mouse, but it still doesn't allow me to use the mouse. Shows that it's ready for use, but can't actually use it

от

Показать 1 больше комментариев

Добавить комментарий

Добавьте свой ответ

Kristen Cash будет вечно благодарен.
Просмотр статистики:

За 24 часа: 5

За 7 дней: 37

За 30 дней: 172

За всё время: 1,392