Not charging; changed battery and Lightning port


I have seen similar posts, but not exactly my case, so I would like to ask for some advice.

I have an iPhone 5. Everything worked well except for the camera. I found another iPhone and took it apart as explained on ifixit to take out the camera. I put it in the other phone. I also changed the battery at the same time (new battery from ifixit).

Everything went well and has been working for some weeks.

Then the battery stopped charging. I noticed when it was caught in a boot loop when plugged. Tried with another battery (known to work), but it didn’t work in my phone. Tried to put it into recovery or DFU, but the phone was not recognized.

But the phone works perfectly with a charged battery, just the charging part doesn’t work.

So I thought that the Lightning port was not working. I followed the instructions on ifixit and switched the port with the one from the other phone (that worked). Result: the supposed faulty port works on the backup phone, the working port doesn’t work on my phone.

But when I plug the phone with a charged battery, it starts at least 50% of the time, so it seems like something works at least with the port, it’s just the charging that doesn’t work.

It must be something else than the port, but I don’t know what. In the other posts, I read things about U2 charging, but that seems too complicated for me. Do you think that there is something else I could try before giving up?

The backup phone I use for parts is locked (icloud), so I can’t just switch phones. But is there something else I could do? Use other parts?

Also: the new ifixit battery is completely dead and I cannot charge it. On my backup phone, I get into a boot loop when I plug it with this battery. But charging works with other batteries. As the home button doesn’t work, I can’t put it in recovery. I have tried to use reiboot, but the phone is not recognized. The phone does not restart when Reiboot is on, but it is not charging either (after 45 minutes). I use a mac or Ubuntu, so I haven’t tried other software that was recommended sometimes but only work on Windows.

Is it possible to give the battery a start somehow? Or is it possible to charge it inside the phone by physically forcing the phone not to start (remember: without home button and a power button not always responsive).

Thank you very much if you took the time to read everything! I just feel that it’s a shame to throw away electronic equipment that works well enough for a basic usage!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий