Weird keyboard and trackpad issue.

I own a 2004 1.5Ghz PowerBook G4 17 inch with a very weird problem, this laptop is an example i have for quite some time, it always worked great, but until recent, as recent as yesterday, it started to acting weird, very weird. What do i mean? Let me describe this as good as i can.

When i push the power button and keep my hands of the machine, let him doing its thing, the screen stayes black after the boing, you can hear the hard drive clicking away reading and booting the machine up, there is no grey screen with apple logo and spinning loading wheel under it (fresh install of 10.4 tiger of an original apple retail dvd, not a burned copy), and when the os is about to finish booting, the screen lights up finally with a blue blackground, than the small box with “Starting Mac OS'“ appears and it boots straight to the desktop, the screen dims a bit because of the ambient light sensors (those work fine), but once on the desktop, i can’t move the cursor with the trackpad and the keyboard is not responding, the caps lock light will light up when i push it, so does the num-lock key (F6), when i push the power button, it responds and asks me what i want to do (restart, shutdown etc.).

Now, let the weirdness begin!

When i power on the laptop (cold boot) with the following keys Option-Command-O-F all held in at the same time, it gets into Open Firmware, no errors here to be seen, its just your regular time and date and copyright info followed with a prompt, when i push all the keys, they all appear, all the numbers and symbol do work. But when i type mac-boot, the screen stays grey, again, no apple logo and spinning loading wheel, when its fully booted, no keyboard and trackpad, only external devices work!

Powering on the laptop with the option key pushed down, shows me a blue screen with my hard drive and optical drive (tiger dvd is still in there), i can move the pointer and the arrow keys do work, but when i choose either of the boot devices, again, grey screen, no apple logo/spinning loading wheel until, or the installer, or the hard drive, boots, with, yes, no keyboard or trackpad.

Powering the laptop on with the shift key pushed down: the screen stays black until tiger is almost done booting, blue screen with a dialog box prompting me to put in the password of the account (empty) with the red text “safe boot” on the top! Once again, no keyboard and trackpad!

I tried everything, changed the topcase with a known good one, booted it up on battery alone as well as only plugged in without battery, changed the pram/usb board, changed os (leopard doesn’t want to boot at all, even with 2gb of ram installed), changed optical drives, changed ram, changed hard drive, swapped cables from other working laptop (i own several broken powerbooks with good parts), nothing what i do resolves this issue, tried zapping pram, pmu, did the reset-nvram, set-defaults, reset all commands in to the open firmware, nothing works, i am baffled in what this could be! Do you know the answer? I tried really every troubleshooting step i could think off. Its driving me crazy because i want this machine to just work, its the only good working model i have!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий