Перейти к основному содержанию

Booted once, but now only black screen

I was cleaning out my old Mac stuff and came across an 12-inch iBook G4/1.33 in a drawer, which I'd put away and obviously forgotten about. Have been trying to revive it, but no luck so far.

I plugged it in, probably for the first time in at least a couple years, and it booted right up. I got to the startup screen and after about a minute I got the flashing question mark. I thought, Great, it works, so I plugged in an external FW drive that I often use to install Leopard, and hit Option, but the drive wasn't recognized. I rebooted using the key combo Power-Command-Control and held Option right away, but from that time onward all I get is a black screen on reboot. I've tried to reset the SMC (removed battery and AC, held Power for ten seconds, then put in battery and AC), but nothing's changed. I also checked the RAM and there was no second bank installed. I installed a working 512MB bank, but still no change. I also put in a new battery I have, but no go.

Any ideas?

Odd that it booted once, right away after years, but that it doesn't boot any more. Or rather, it boots, I hear the chimes and the HD and DVD starting up, but nothing.

The HD or the DVD make some noise, and there seems to be 2 beeps on startup, though it's hard to tell. They're not the typical beeps right away at startup (e.g., 3 beeps for bad RAM), but about 5 seconds after the chimes there's one beep, and then after another 5 seconds another beep. Though they could be grinding sounds from the HD or DVD.

What steps would you suggest?

I have a couple HDs lying around that I could try to install. But if it's unlikely that this would solve it, I'd rather avoid the pretty tough job of replacing the HD, and maybe sell it off for parts.

Any help greatly appreciated.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
2 Комментариев

do you have flashing lights at the front? should tell you the code ( like beeps too..)


also try an external monitor to see whether the problem is with your video card or the cable controlling LCD.


Добавить комментарий

Ответов (1)

Выбранное решение

If it is not posting chances are the HDD is not the issue. I see if it posts with an external monitor first. If it was in an area that was subject to extreme temperature swings something may have happened to the LCD. This logic board does also have an ATI graphics chip on it which I have problems with in the past. Generally with apples the beeps coincide with flashes from the power LED so if there are no flashes I would say it is not throwing a beep code. If it does not post externally I would take it apart to to expose the BGA chips and try to heat the ATI chip on the board up and see if it posts then. Use a hair dryer or heat gun but do not go over around 175C. You are not trying to reflow the chip just heat the connections under the chip. I have used this method to see if there is a BGA issue quite a few times. You should be able to just short the two points in the connector that the power plugs into to start the laptop up so you do not have to put it all the way back together again. You could also leave it sit for a few hours or even overnight and see if it starts posting again. If this is the issue you could try to reflow the graphics chip or just buy a new logic board. there are some available on ebay for $55 from a vendor that I have used in the past...


Был ли этот ответ полезен?

Оценка 1

1 Комментарий:

Just which chips are ball grid array?


Добавить комментарий

Добавьте свой ответ

Simple Simon будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 0

За последние 7 дней: 4

За последние 30 дней: 10

За всё время: 1,159