Перейти к основному содержанию

The larger of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

Вопросов 466 Показать все

Disk not recognized after logicboard replacement, but SSD is fine

I have a 2013 Macbook Air and I bought a logicboard that was either exactly what I had or close. (I couldn’t remember the precise ghz or RAM.) Installed it with the help of ifixit, seemed fine, but when I try to boot up, I get a flashing folder with a question mark. I can’t boot into safe mode and select a start-up disk, my only option is Internet Recovery…

  1. Once I get to those options and I go to Repair, I am able to see my desk and verify it. The verification process says it’s OK. I repaired it anyway and it didn’t do anything…
  2. Then if I try to reinstall OS X, it asks me where to install Mountain Lion but there are no disks to choose from so I have to exit out of it.
  3. If I try to to restore a Time Machine backup, it can’t find any.
  4. If I try to change my startup disk, there are no disks listed. My only option left is to shut down.

So, my disk is there and the Macbook sees it in the Repair utility but nowhere else. I also removed the SSD from the laptop and plugged it via USB into a spare 2012 Macbook Air with a chassis I bought, and I am able to boot up from it on the other Macbook Air, so I know the drive works and boots up. SMC and PRAM reset didn’t work.

I don’t remember which version of OS X I had installed on my Macbook Air before I killed the logicboard (I can check if it matters, I think), and I don’t know what OS this used logicboard had, so I don’t know if there could be a communication mismatch, but I am at a loss on what to do next. I have a slow 2012 Macbook Air and a Windows 10 PC at my disposal to try to make this work. I’m just not good with Macs. Thank you!

Update (08/22/2021)

So, it was a bit of a headache, but I finally got my Macbook Air working with @danj’s instructions. I did try to just use a blank USB (after having to figure out how to properly format the drive) and go through the internet recovery prompts to install Mountain Lion and then upgrade. It started OK, I got Mountain Lion installed, but it could not upgrade for some reason and I was getting error messages at the end, something about the wrong firmware - I don’t even remember. So then I decided to just try to do a High Sierra bootable USB, but the version of High Sierra that Apple provided in the Apple Store was not the full installer (a known problem), so it wouldn’t work. The recommendation I saw to get the correct High Sierra installer was via non-Apple sources, so I opted not to do that and go a safer route. So then I tried Mojave, as Dan recommend, and I kept getting error messages during installation. First the disk was “locked” and I couldn’t figure out how to unlock it. So I got a second USB to finish the process with a disk that was not locked, and then I kept getting an error message saying “the installer resources were not found.” I kept trying, and I put my internal SSD inside the laptop, and somehow after like three times it worked and installed Mojave off the one USB and onto the other USB. Once Mojave was installed on the USB, I shut it down, removed the USB drives and tried to boot off the internal SSD and voila, my Macbook Air was alive again running High Sierra and looking exactly as it did before I dropped it in the sink.

It was a headache and took all day because of all the random errors I kept encountering, and it required a lot of googling instructions and trial-and-error, but eventually it worked. The issue was definitely 100% that my SSD was formatted as APFS and the logic board I put in there only recognized HFS. Apple switched over from HFS to APFS with the introduction of High Sierra, so “teaching” my logicboard how to recognize APFS by getting High Sierra or later installed was the solution. For anyone who sees this, as long as you can find a way to do that, you’ll be all set.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

Ответов (2)

Выбранное решение

I think you’ve fallen into the crack! Halfway between HFS+ and APFS!

Apple updated its file system from HFS+ to APFS and from the sounds of it your original system was using High Sierra (10.13.x) or upto Big Sur (macOS 11.x)! But the logic board you got likely still had the older firmware which doesn’t know how to boot up under APFS and of course! Mountain Lion has no clue about it either so it can’t access the drive and won’t let you install as there is no room as the drive already has the partition laid out as APFS!

OK, how you get out of this mess? You’ll need to use another Mac to create a bootable USB thumb drive OS installer. We need one that is able to update your systems firmware to APFS support. So I would use Mojave. First use your other Mac to format the 32GB USB thumb drive with GUID and a journaled file system. Then download Mojave from here How to get old versions of macOS and follow this guide to convert it to a bootable image on the USB thumb drive How to create a bootable macOS Mojave installer drive

Then using it you’ll boot up under it but we have one small wrinkle! We don’t want to damage your current OS on your internal drive as such we need a second external drive (USB or Thunderbolt) to install the OS and during that process the firmware will be updated.

OK, now we have a bootable USB thumb drive with Mojave and you should now be able to see your internal drive, booting up under the temp drive If you do you should be able to figure out what your systems OS level is, unless you can remember. Then upgrade this USB temp drive to that OS at which point you only need to then alter your startup using the Option key to gain access to the Startup Manager and then set it permanently via your Startup Disk control panel.

Reference: Mac startup key combinations

Update (08/17/2021)

The Ins and out of FileVault2 Analysis-of-FileValut-2--Apples-Full-Disk-Encryption-(2012).pdf

Был ли этот ответ полезен?

Оценка 2

8 Комментариев:

Hi @danj, thanks for the reply. I checked my SSD by hooking it up to my other Mac, and it looks like the disk does use "APFS (Encrypted)" and the OS is High Sierra. The person who sold me the logicboard doesn't know what it originally used, but he said he tested it with an external SSD that is formatted to HFS+ on Catalina.

I can follow your directions, however, if I don't care about wiping my hard drive and starting from scratch, is there an easier way to do this? Or would this still be the best method either way? This Macbook Air is old and I got it through my ex-employer after I was laid off, so I don't have any official credentials of me owning it, if that's necessary, since I wasn't the person who originally bought it and my employer went out of business. (I wiped it clean after I was laid off and started from scratch then.)

Thanks for your help!

из

@applewindow - If you don't have the recovery key for the drive, then you don't have any options you'll need to reformat the drive. Using the OS installer as I've laid-out above will allow you to exit out of the installer to then gain access to Disk Utility to then wipe the drive down.

You'll need the APFS version of Disk Utility (Mojave). Don't use High Sierra it has issues!

из

@danj Not to be an idiot, but what is a recovery key? I can boot up from the drive just fine when I hook it up to my other Macbook, so I should be able to view all the security settings for it, no? It boots up via USB as if my old Macbook has been resurrected from the dead. The dead Macbook I'm trying to revive with the replacement logicboard is also connected to my Apple account and registered to it - I took to an Apple store to diagnose it originally. So I probably can get the recovery key, if it has one.

из

@danj Actually, if you mean the file vault password, I have that saved, so I have it.

из

@applewindow - I've added a writeup on FileVault2 in my answer which will help explain things, but if you have the password then you can gain access to your stuff which you 'll want to backup and then reformat the drive.

I really don't recommend FileVault on the boot drive as it prevents recovery or drive repairs.

из

Показать 3 больше комментариев

Добавить комментарий

Thanks, @danj. Same issue (after changing the logic board and keeping my original SSD - where I installed Mojave. SSD is not visible) but when I am using the Mojave bootable USB thumb, all possible drives (all external USB thumbs, in one I have the current OS Sierra 10.12.6 ... the last possible updates I was able to perform) are light grey and they can not be used with the following message "You can not install on the volume because the computer does not have a firmware partition". I tried all your suggestions but none is working. Any more suggestions? Thanks in advance

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

Think it through! Here’s a way to see it physically…

Your shoes heel came off, you spy a shoe cobbler down the street you walk in asking if he can fix your shoe! Why yes he states you lift your leg plopping it on his bench. He looks at you, you look at him, he looks back.. clearly he can’t fix your shoe as your in it!

So you need to take the shoe off but the dollar you had tucked in the toe will be lost if you do. Now what??

First the data on the drive needs to be saved if you don’t have a backup. So that will require connecting this system via target disk mode to a second Mac or removing the drive installing it into a case which supports it to then access from the second Mac.

Then you can reformat the drive with the proper OS this System can support.

из

Добавить комментарий

Добавьте свой ответ

Catalina будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 1

За последние 7 дней: 8

За последние 30 дней: 13

За всё время: 840