Перейти к основному содержанию

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

581вопросов Показать все

Panic : Unable to find driver for this patform MacBookPro9,1

Hello everyone,

A couple of days ago I finally decided to replace the motherboard of my old MacBook pro 2011 with another one from 2012 year. The reason is obvious and sad - dedicated GPU issues.

So my previous motherboard model is 820-2915-A, and the new one is 820-3330-B. I swapped motherboards without any trouble. Then I tried to boot and stuck on Apple's logo, it didn't surprise me and I decided to reinstall macOS. I use my previously prepared USB flash with Catalina patcher by dosdude. I successfully booted from this flash, tried to reinstall Catalina, got the message 'Not enough space on HDD' and it was fair cause it hasn't been formatted. But then instead of doing proper steps and try again, I applied the post-install patches. It was a stupid mistake, but for some reason I did it..

Now I'm not able to boot from any devices or recovery, anything I try I get stuck prior to initialization. Even if I remove HDD and try to boot from USB, or internet recovery - stuck on Apple's logo. Of course, I tried reset SMC, PRAM, NVRAM but it does not help. The only maybe helpful information I can get during boot is single user mode booting logs. It shows something like that in the middle of the logs:

panic "Unable to find driver for this patform: MacBookPro9,1"​

Also, I attached the screen of the latest log message during boot, sorry for the quality.
I hope my MacBook is not totally bricked, please kindly help. Any suggestion, any clue how to solve it really appreciated.

Block Image

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Hopefully you haven't corrupted the systems EFI (BIOS)

You'll need to create a bootable USB thumb drive OS installer with Sierra! Hopefully you can get it to reformat your drive and install the OS. You'll need to use another Mac to create it which is running the older OS as the newest macOS versions won't let you create the older OS drives directly.

Otherwise you'll need to have someone return your systems EFI chip.

Был ли этот ответ полезен?

Оценка 0

7 Комментариев:

@danj, thanks for your advice. Yesterday I tried this, I created Sierra bootable usb on Catalina Mac using createinstallmedia command. But when I'm trying to boot from that, the progress bar is stuck on the same level as I boot from hdd. Today I'm going to try Mavericks.

Does it make sense if I create a boot usb from Catalina?


@kirillcy - Did you wipe the drive (remove the partitions and reformat the drive). If had then this is looking like the drive or the systems EFI firmware is messed up.

Are you able to boot up using an external bootable drive? Use the Option (⌥) key

Reference: Mac startup key combinations


@danj I ran Apple hardware test today, using command+D combination on boot, it successfully started, but after an hour progress stuck and I decided to restart mac and try again. The strange thing is the system booted up normally into my previous Catalina on hdd! I've seen just small GPU glitches sometimes, guess due to the absence of correct drivers. So I created installation Catalina usb, loaded from it, format hdd and started the installation process. It was going smoothly, until after one of the reboots I got the black screen again... I noticed that mac was really hot. But anyway I faced again with black screen problem, now on mid-2012 model...


@kirillcy - This sounds like you are hitting two issues on the 2011 logic board! First Catalina is not a supported version, the highest is macOS High Sierra (10.13.6) and you are indeed hitting a GPU issue as well a well known issue in this series.

I also think your system overheating is do to a bad SATA cable which is also a known issue! Your Hard Drive Cable Is A Ticking Time Bomb And if you creased the cable at the bend points you'll likely weaken it as well which is a common issue when people mis-handle the cable. This is more pronounced with SSD setups as the higher data flow causes the system to work hard to overcome the heavy CRC errors being created from the bad cable.

So lets get back to the 2012 logic board... Where are we there?


No idea what to do now( I bought this 2012 motherboard on eBay, maybe dedicated gpu is faulty who knows.. Can’t turn it on now at all, nothing works, just black screen


Показать 2 больше комментариев

Добавить комментарий

Добавьте свой ответ

Kirill будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 1

За последние 30 дней: 4

За всё время: 169