Перейти к основному содержанию

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1202вопросов Показать все

Why is Macbook's USB only working at USB 1.1 speed?

The front USB port on my black Macbook no longer works. The rear port only works at 1.1 instead of 2.0 speed. I'm not entirely sure when the problems started. But I can think of two points of trauma the machine has suffered. Over a year ago, I spilled some distilled water into the back of the machine. But after it dried out, it booted up without a problem. I don't recall any USB troubles at that point.

Most recently, I replaced the hard drive, but accidentally re-inserted the caddy upsidedown. I believe the caddy scraped something along the top of the inside of the case. But I reinserted it properly and the machine booted. The USB trouble may have started around the time of this incident, but I'm not absolutely certain -- it could have been before.

The USB problems definitely seem to be hardware based -- they're there when I'm booting up from the internal drive or an external drive and in Leopard and Snow Leopard.

I'm curious if anyone knows what kinds of specific physical damage might cause this kind of problem and if there's any hope of a repair short of replacing the motherboard. I'd be particularly grateful if anyone could share details about how the USB ports are connected to the motherboard and what enables them to work at 2.0 rather than 1.1 speed.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий

3 Ответов

Выбранное решение

The hard drive is about as far away from the USB ports and the associated components as you can get inside a MacBook, in fact there is nothing sensitive you could damage by putting the drive in upside down.

That being said, the liquid spill is the most likely culprit - the damage can continue over time, as corrosion can still occur after the liquid dries. Remove the top case and look for signs of corrosion on the logic board and along the back of the USB ports.

MacBook Core 2 Duo Upper Case Replacement

good luck!

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

Clean the corrosion with a stiff toothbrush and some contact cleaner, and canned air... (the corrosion could be underneath the board) be sure the contact cleaner dries before firing up the machine.

Good Luck,


Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

This may be a dumb question, but you don't have a hub plugged into the working port, do you? IOW do you see the slow speeds when the device is plugged directly into the port?

Был ли этот ответ полезен?

Оценка 0

3 Комментариев:

Nope, no hub. Yes, the slow speed happens when any device is plugged directly into the port, alas.


Well, I always try all the software possibilities before concluding a problem is hardware. You've tried different drives/OSs. That's good. Have you zapped the PRAM? Reset the SMC? http://support.apple.com/kb/HT1411?viewl...


Yep, tried all that. None of it worked, unfortunately. Pretty sure it's hardware related.


Добавить комментарий

Добавьте свой ответ

mister790 будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 1

За последние 7 дней: 1

За последние 30 дней: 3

За всё время: 2,756