Frozen on the VTECH logo, no response to anything.

On 10/15, the VTECH watch, which was being worn at the time by my sister, ended up freezing on the time. When my sister gave this to me [because she knows I'm the "tech guy"], it felt Very warm, possibly an overheat. It was stuck on the clock until I flipped the master switch to OFF. I let the watch cool down, then I flipped the master switch to ON and placed it on the charger, but it now shows the VTECH logo, without response. I tried the "Missing Battery" test, which involves flipping the master switch to OFF and placing it on the charger, which should have warned me about the switch, but it only showed the VTECH logo, nothing else. I tried leaving the master switch OFF without leaving it on the charger for a minute, then flipping it on and powering it on. VTECH logo, nothing else. I'm stumped and don't know what to do next. Any suggestions?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0

5 Комментариев:

Hi @jri_creator,

Maybe try turning off the master switch and then press and hold the home button for approx. 30 seconds then release.

Turn on the master switch and check


I've tried this method, didn't work. Still stuck on the VTECH logo. I'm going to see what happens when I drain the battery. [If the MASTER SWITCH is set to ON, and you remove the charger once you see the VTECH logo, it stays on the logo]


BTW, I think the watch is a DX3, not a DX.



Seems like the Master Switch isn't disconnecting the battery like the manual says it does.


What should I do to fix this Master Switch problem? Is it easy to repair?


Добавить комментарий