Startup sudden shutdowns (Cannot open Recovery)

Hey guys,

So around two months ago I started having the following problems:

MacBook won’t power on and got super hot

At the time I was in the States, however I have returned to my home country and actually had time to give the laptop another try and the problem is still here.

Booting up is very unreliable, sometimes I get the bell and only black screen, sometimes it boots and I am able to login. Sometimes it crashes after the login during the progress bar. And if I am lucky it will boot up and I will be able to use it, however if I put it to sleep it might crash/shutdown, “might” because I have had some successful sleep and waking it up after 2 or 3 hours.

Shutting down also acts up, it does not shut down “correctly”, just seems to crash and turn off.

And here is where it gets weird:

  • Recovery mode crashes/shutdown when loading, and although I have tried around 10-15 times I haven’t got it to finish the loading.
  • Online Recovery mode goes through all of the wifi setup and then crashes on loading.
  • Apple Hardware Test mode does not work offline and tries the online method however after I press “Test” it crashes after the first pass.

I have gotten 2 system reports, about a Kernel panic, both relating to GPU: (both from rare times where has it boots up the macbook recognises it has shutdown because of a problem and displays message)

anic(cpu 0 caller 0xffffff7fafd258d7): "GPU Panic: mux-regs 5 0 a0 d9 9 8 severity 3 WS-ready 1 switch-state 0 IG FBs 0 EG FBs 1:f power-state 0 3D idle HDA idle system-state 1 power-level 20:20 connect-change 0 : NVRM[0/1:0:0]: Read Error 0x00000100: CFG 0xffffffff 0xffffffff 0xffffffff, BAR0 0xc0000000 0xffffff92333cd000 0x0e7150a2, D0, P0/4\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.20.13/src/AppleMuxControl/kext/GPUPanic.cpp:170
/38

panic(cpu 0 caller 0xffffff7f8538d8d7): "GPU Panic: mux-regs 2 0 a0 d9 9 8 severity 3 WS-ready 1 switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle system-state 2 power-level 15:0 connect-change 0 : NVRM[0/1:0:0]: Read Error 0x00137310: CFG 0xffffffff 0xffffffff 0xffffffff, BAR0 0xc0000000 0xffffff91f6739000 0x0e7150a2, D3, P0/4\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.20.13/src/AppleMuxControl/kext/GPUPanic.cpp:170

I have ran Disk Utility on the SSD and it gives back an “OK”.

I have tried using GFXCardStatus and I can force both the Discrete GPU and Integrated GPU and computer still runs fine.


I have also reseted PRAM, NVRAM and SMC. (reseting PRAM/NVRAM brings back the bell)


I have an iFixit toolkit and I am more than comfortable with opening it up, however I am not sure what to look for.

Thank you in advance for all your help!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий