Перейти к основному содержанию

Repair and service information for Western Digital Elements external storage drives.

12вопросов Показать все

Cannot be recognised through my mac

i have a newly bought 2017 13.3” macbook pro and i also bought something called a satechi USB C pass through hub to connect usb-A devices to my macbook.

Originally my external hard drive would show up and i could transfer with it but suddenly it stopped showing up on my mac, i believe it’s might be due to me pulling out my hard drive without ejecting first, it works on my other laptops and another mac that i have but not on my new one, i also believe the problem might be the usb c pass through hub or my mac (which i doubt because it’s newly bought) USBs work but not hard drives!! please help.

it cannot be seen in disk utility nor terminal via diskutil list and i’ve also checked finder preferences for the checkbox for external drives. I’ve tried factory resetting and also updating MacOS. It also says it has malfunctioned and cannot be recognise when i use bootcamp

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

I think this page explains your situation… https://support.wdc.com/knowledgebase/an...

and it provides a suggested solution which sadly involves using a windows computer to clear a flag some place in the drives filesystem metadata content.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий


I think you should tried to plug the drive in a computer running linux (On a usb stick if you don’t want to install it)

Then save your files on the computer and use GParted to format the drive in exFAT

You can also check on Apple forum, maybe they have the solution (And if so please put a link to the topic here)

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Alv H будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 1

За всё время: 497