Перейти к основному содержанию

1.6 or 1.8 GHz dual-core processor, 2 GB or 4 GB of SDRAM, 64 GB or 128 GB SSD

186вопросов Показать все

Is my battery bad or just not charging?

Block Image

So I haven’t turned on my MacBook Air in a while and I was expecting to encounter SOME issues, so when it wouldn’t turn on at first, I wasn’t surprised.

It stayed that way when I plugged it in and I didn’t get any orange light to indicate on the MagSafe charger. I opened it up and took a look. Disconnected and reconnected everything and closed it back up. Tried resetting the SMC - nothing.

Then I plug it in and decide to just let it go for a while. “Maybe I’ll get lucky I think as I walk away.” And then I heard the chime.

I turn around and sure enough it’s turning on. But it says 1% then 0% once I’ve logged in. The battery isn’t charging, but the MagSafe is keeping the system on. That’s weird. So I check the battery and get this from CoconutBattery:

  • Current Charge - 0 mAh
  • Full Charge Capacity - 3101 mAh
  • Design Capacity - 4680 mAh
  • Cycle Count - 79 (!!!)
  • macOS Battery Status - Poor
  • Battery Temp - 21.8°
  • Charging with - 0 Watts
  • Power adapter - Connected

So it looks like it’s registering the MagSafe power adapter, but the adapter won’t charge the battery… But also the battery doesn’t seem “dead” because it shows that there’s a 3101 mAh capacity right now that it’s just not recharging.

Is it possible I disconnected something while I was in there and I just need to open it back up?

Based on everything I’m seeing it should be working, no?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0

Комментарии:

To be clear the MagSafe charger LED is not lit at all? IF lit what is the color Amber or Green? Bright or very dim?

Review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters Lets make sure the charger its self is in good shape.

Is this the original charger that came with your system? Its possible a fake charger damaged your system How to Spot A Fake Macbook Magsafe Charger

из

Hi Dan! The charger was not lit originally, but now it is a bright green (I think maybe it was just cold?) - evenso, Coconut says no charge is happening.

Tried "zapping the PRAM" and resetting the SMC, but it doesn't seem to click with the charger that the battery is not at full charge.

The charger is the original, so no fakes here. And according to Coconut it's showing the charger is 45 KW, but just not charging the battery. I'll check out that page though.

из

Post a snapshot of the apps window post it here for us to see Adding images to an existing question

из

@danj I added the snapshot of Coconut and I also found my longer thick extension cable to attach to the power brick. Same results. Power is making it because it can turn on, the battery just won't charge despite saying it has the ability/depth to do so. :\

из

Добавить комментарий

2 Ответов

Наиболее полезный ответ

Yes it should be working… anything from Apple is advanced and I would suggest going and getting the battery tested just in case… The charging port in the PC might be loose or corroded… I would then get it checked out by Apple experts to see if they can find anything… at that point you would be out of luck and have to buy something new… Hope this is at least a little help…

Был ли этот ответ полезен?

Оценка 1

Комментарии:

@communist_geek - I think the battery its self is still workable here. More likely the charger and the charging logic inside the system needs to be investigated given the symptoms.

из

Добавить комментарий

Sadly, your systems logic board charging logic is damaged. You’ll need to find someone who can fix it or you could just replace the logic board MacBook Air 11" (Mid 2011) 1.6 GHz Logic Board and the guide MacBook Air 11" Mid 2011 Logic Board Replacement

Consider the cost and the limitations of this older system.

MacBook Air 11" (Mid 2011) 1.6 GHz Logic Board Изображение

Продукт

MacBook Air 11" (Mid 2011) 1.6 GHz Logic Board

$79.99

Был ли этот ответ полезен?

Оценка 0

Комментарии:

Thanks for the diagnosis. Can I ask what specifically lead you to that conclusion? The reason I ask is because I've already had the logic board repaired/replaced by Apple just a couple years ago and I've clearly barely used it. If this is the real reason for the failure then I'm happy to just forget the whole thing and leave it as a non-portable unit since it still works plugged in.

I already have a surface pro that works better than this thing ever did. If I've honestly repaired this issue and it's doing it again then I think I can safely say Macs are pretty worthless. Should have never paid for the overpriced repair to begin with.

Thanks for the heads up though. Was in the process of buying a battery but I'll probably cancel it.

Any chance it's just the io port? Or is that unlikely since it works plugged in?

Thanks again.

из

@shadow64 - Sadly, Somehow the charger damaged your charging logic. I've seen metal shavings short out the middle pin which then burns the MOSFET's which control the direction the power goes from the charger. Her the logic is stuck in a state that only powers the logic board and doesn't really charge the battery.

You will need a new charger as it is the source of the damage as well as getting a new logic board or finding someone with the skills to replace the damaged MOSFET's

из

Добавить комментарий

Добавьте свой ответ

Danny будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 9

За всё время: 466