Перейти к основному содержанию

A1708/EMC 3164 — Released June 2017, this entry-level MacBook Pro retains its traditional function keys (as opposed to the OLED Touch Bar).

444вопросов Показать все

A1708 MBP does not always reboot after installing a custom ssd

Hey guys!

A few days ago I swapped the factory-installed 128GB SSD for a Sabrent 1TB Rocket NVMe PCIe M.2 2242 SSD on my 2017 MacBook Pro without a touchbar. The installation itself went without any problems and the new SSD was recognized immediately.

With the help of an external recovery stick, I first formatted the new SSD as APFS and in the GUID partition scheme and then installed Big Sur. During the installation where the MacBook had to restart several times, I noticed that the MacBook shuts down, but then I had to restart it manually because it didn't do this by itself. Big Sur is now fully installed and I have all my data back via a Time Machine backup, but it still seems to have a problem when restarting:

It switches off, takes about 15 seconds, then switches on again and then shows the folder symbol with the question mark - it does not seem to recognize the hard drive.

If I then manually shut it down again and then boot into recovery mode with cmd + R (sometimes it is the Internet recovery and sometimes the system-internal recovery, booting into recovery mode from usb drive works as well) and then shutdown the macbook in this mode and then start it again, the macbook booted without exception and without any problems always normal to MacOS.

After this procedure when I am in the operating system, the following appears in the error report:

MCA Error Report CPU Machine Check Architecture Error Dump (CPU: Intel (R) Core (TM) i5-7360U CPU @ 2.30GHz, CPUID: 0x806E9) CATERR detected! No MCA data found.

Strangely, if I shut down the macbook normally and then turn it on again, this problem does not occur, so that the mac then boots normally into MacOS.

Things I've already tried to solve the problem:

  • SSD completely erased again, reformatted, installed the factory-installed MacOS Mojave and updated from there up to BigSur
  • PRAM / NVRAM & SMC reset
  • deactivated FileVault and restarted
  • started in safe and verbose mode
  • rapaired the ssd in disk utility tool several times
  • with 'bless -mount "/ Volumes / Macintosh HD" -setBoot' set the hard disk again as the start volume and restarted, here I have deactivated SIP beforehand, because this command otherwise failed with "Could not set boot device property: 0xe00002bc"
  • tested MacBook with apple diagnosis (held D key at startup), ended with ADP000 - No issues found.
  • adjusted power management settings with pmset command to counteract the rapid discharge of the battery

All of these attempts were unfortunately unsuccessfull.

I'm really desperate. Does anyone know a solution?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 4

Комментарии:

My adapter is “NFHK N-1708A”, name and detail color gold

из

I have the same problem with you, did you sort it out in any way?

из

No, I sadly didn’t solve the problem. :(

из

I ordered another SSD Sabrent with his adapter, I'll tell you if I solved the problem in a few days

из

Hi

I have same problem with Sabrent 2Tb ssd and Sintech adaptor, I tried with another adaptor but didn't solve the problem. wondering to order another Sabrent ssd ... waiting for your report.

из

Показать 12 больше комментариев

Добавить комментарий

16 Ответов

Наиболее полезный ответ

Sadly, your SSD replacement is giving you problems ;-{

Time for a replacement of either the carrier or the M.2 SSD its self or both!

While its more expesive (sadly) you might want to get a real Apple SSD Custom Apple 1 TB SSD

Был ли этот ответ полезен?

Оценка 3
Добавить комментарий

I have the same problem. Same Sabrent Drive and same Amazon adapter.

I had the folder icon at startup when installing macOS through internet recovery.

No I don’t have the folder icon at startup after installing from usb drive.

I still have the restarting problem though. It does not seem to be better at a certain version of macOS. I tried High Sierra, Catalina and Big Sur. Same problem.

But when I try to restart it still gives me the exact same error message as above.

I found a German forum where they seem to have a similar problem. Their suggestion is to unplug from power before restart if I understand correctly. It didn’t work for me though.

https://www.macuser.de/threads/macbook-p...

I hope someone will find a workaround!

Был ли этот ответ полезен?

Оценка 2
Добавить комментарий

Ive been using sabernts 2TB ssd since august, and have been dealing with this issue from the start.

  1. When your laptop dies from battery loss keep it plugged in and let it charge for 10 mins before opening the lid it wont cause issues
  2. keep your laptop plugged in if your leaving it overnight, it won’t cause a shutdown
  3. if you end up with the folder logo, shut it down, wait a few minutes and make sure nothing is plugged into it and press the power button again it will boot up. (if it shows the screen turn on and off, just press the button again, dont spam it)

You gotta be patient with it when it happens but i would rather take this headache over having 128gb storage anyday.

Был ли этот ответ полезен?

Оценка 2

Комментарии:

You're fighting a loosing battle ;-{

These adapters and M.2 SSD's are just not as good as the original Apple SSD's. Being still a different interface from the older systems that this series had doesn't help.

The two folks I recommend them to took them out and sold their systems with the original drives as they just couldn't handle the problems.

из

Добавить комментарий

Try physically removing the component, check for dust / hair on the contacts. Then re-install. I've had a similar problem with a video card installation on an m17x. One of my wife's hairs made it into the contact bar. Sometimes the simplest solutions are the best. Also, make sure you are grounded! When the case is open, it is no longer a faraday cage, and several thousand volts of static electricity can be transferred to the motherboard without you ever knowing, especially in low humidity conditions.

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

UPDATE

If i install catalina i have no issues but as soon as i update to big sur 11.2 and 11.2.1 thats when i get the issues

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Interestingly, maybe it's an OS problem then. What idea for the resolution?

из

Is there an alternative way to install the latest OS cleanly? Maybe with disk partitioning?

из

this is what im thinking because when i install catalina i have no issues

the errors seem to happen when i upgrade to big sur 11.2 or 11.2.1

iv also put the new ssd in an enclosure plugged it into the mac and wipped the drive reinstalled catalina upgraded to big sir restored from one of my time machine back ups and it works perfectly

the issue i keep getting is when i intall the the new ssd into the mac

из

Today Apple has released the new OS 11.2.2, try to check now who knows they have solved

из

Добавить комментарий

UPDATE:

I returned both of my Sabrent SSD, bought a Samsung 970 EVO Plus, and the problem is gone. Unfortunately the Samsung does not have the 2242 version so I opted for the 2280 (I hooked it up with electrical tape)

I reported the problem to Sabrent after contacting Apple support, according to Apple it is an SSD compatibility problem with BigSur.

Here's how Sabrent answered me:

““Thank you for contacting Sabrent support.

My apologies for the inconvenience that this has been causing you. Unfortunately, we do not have a firmware update for this incompatibility issue. I recommend you stick to the Catalina version while Apple releases, new features and updates while taking into account their customer feedback””

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Can someone confirm this fix?

из

Добавить комментарий

I have the same problem, and I have not found any valid solution.

The problems I usually have and the solution I have used are:

1. When you get an update and the computer needs to reboot, it doesn't reboot automatically. I have to have the power cord disconnected and hit it manually when it won't boot.

2. When the computer is connected to the power and I open it, it usually does not start and the folder icon appears with the question mark. The solution is to hold the power button, turn it off and turn it on by disconnecting the power cord.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Yes same problem here I'm using Sabrent 1TB ssd in Macbook Pro A1708 and it will restart after a few minutes but get the error message that it was shut down due to a problem. If you shut down and restart it works fine. I know it's the ssd because I have a Samsung no-brand 500GB 2242 and it works fine but the read write speeds are really slow compared to both the original 256 GB drive and Sabrent drive. I sure hope someone figures out an answer to this problem. I don't want to go back to the old Mac ssd.

из

Добавить комментарий

I don't think anyone has an answer to this problem the Sabent 1TB drive that I was using was a real energy hog so I stopped using it and went back the the original 256 GB drive. I think these laptops are too old now to upgrade or waste anytime figuring out the problems. It's time to upgrade to a new Mac unfortunately. Good luck.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Frustrating.....just...... :-(

из

@Paul Carvill - I would look at getting a real Apple drive Generation 5 I can tell you they do work!

из

Добавить комментарий

The key is choosing right SSD and Adapter.

Pick one with Silicon Motion Controller, and 99.99% you will be fine. Other controller like Phison, WD, Samsung, etc not always playing nice with A1708.

If you happen to face the question mark upon reboot. Key is, not to reboot, but shutdown instead. It will detect the SSD just fine when turning on.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Can you please provide a brand name and model number?

из

Добавить комментарий

I’ve had issues with my iMac restarting while not using it and this “CATERR detected! No MCA data found” has been occurring a lot lately. I am on Big Sur 11.2.1. I have a 3rd party SSD (Samsung) and I have a Sabrent Thunderbolt 3 dock, and a thunderbolt sound card (UAD).

I am keeping the sound card off for now, but it’s interesting the name Sabrent is something we have in common.

Был ли этот ответ полезен?

Оценка 0

Комментарии:

I also have this problem ...exactly as described Sabrent 1TB SSD in A1708 MBP. :(

из

Добавить комментарий

my “restart” problem happens on Mojave and Catalina both OS. i have not tried BigSur.

i had sabrent 2Tb and sintech adaptor ( and another no brand adaptor ) on A1708, 2017 MBP function key.

i sent back the ssd and going to get refund for adaptor.

i found couple of SSD ( looked like combined 2240 ssd + adaptor ) with working guaranty for A1708 on eBay US but up to 1TB, since i need 2TB, I ‘m using external USB case with my old 2012 MBP 2.5’SSD (mojave ), it takes little longer to start up but no issue.

right now i ‘m not travelling , so this external system is ok but for the future when the pandemic goes down i will travel a lots like before and i will need decent internal system, i ‘m still looking for solutions.

i don’t know who is making 2240 ssd 2TB beside sabrent. and all adaptors looked same on amazon and eBay.

Был ли этот ответ полезен?

Оценка 0

Комментарии:

Have you tried looking for KingSpecs?

из

i don't find KingSpec ssd fits into A1708 in my amazon (JP), do you think it would work ?

из

i have spoke to one off the king spec sellers on ebay and he said hes having issues with big sur

из

Добавить комментарий

I was facing same problem but with apple original ssd if I downgrade the OS from BiG Sur to High Sierra. Then I reinstall Bigsur and now working fine for

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

have some one solve that problem now? i have exactly the same problem

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

It’s really hard to say what fixed mine but suffice to say it rarely reboots anymore. My system actually seems more stable on Monterey and has been substantially better on 11.3+. Of course I have other issues but they are likely unrelated. All I can say is try a PRAM reset as that seems to help get boot issues fixed.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Also having issues with the same errors after upgrading to a 2TB Sabrent M.2 2242 (via Sintech M.2 NVMe SSD Adapter).

Upgraded from stock 128GB to the 2TB above and installed Big Sur to match my Time Machine backup. OEM SSD was on Big Sur so decided to install the same to be safe even though Monterey / MacOS 12.x is out.

Struggling to understand where the issue is coming from. SSD firmware? That, at least, would make sense.

Был ли этот ответ полезен?

Оценка 0

Комментарии:

I have the same problem which is annoying. My Macbook rejects it when rebooting to finish the install.

из

Добавить комментарий

Hi guys,

Last Monday I upgraded my MacBook Pro’s 2017 A1708 SSD because the original one died. I purchased an OWC Aura Pro NT 240gb SSD because it was I think the most compatible solution I could think of. By the time I upgraded i’m experiencing the following problems.

  • My machine cannot execute a restart (I restart the MacBook and it takes about 30 seconds to boot back again and when it opens it displays a windows indicating that My computer was restarted because of a problem)
  • When the machine is shut (with closed lid) I connect the power cord and I get no charging sound, when I open the lid in order for the Mac to boot to the OS I get a folder with a question mark.

My guess is that anything besides the original Apple SSD will not operate normal in Macbook’s. Is there any possible solution to this issue?

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Lukas будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 9

За последние 7 дней: 59

За последние 30 дней: 228

За всё время: 4,772