Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

9th generation of Chevrolet's full sized SUV, based on the GM GT800 platform.

23вопросов Показать все

Engine bogs down and stutters under hard acceleration

I have a 1994 chevy suburban (didnt give that year option when choosing for post) with the 5.7L gas engine. She idles fine, revs fine in park, but when I go to drive, if I accelerate hard she bogs n stutters. If I'm in 4th gear and try to accelerate, same thing. I can only accelerate very slowly once in fourth gear. Engine bogs down, trans doesn't seem to even try to downshift to help accelerate. Trans was rebuilt a couple years ago, and I'm trying to figure out what is broken so I can fix it! Distributor is less than one year old. Am going to replace fuel filter. Don't think that's the problem but I'm doing it anyways. My father checked it out and said it smells like its running rich. Could this be causing this? Should I replace o2 sensors?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Hi @brandon_k

Have you tried checking the OBD codes, just in case they might show something, you never mentioned it?

Don’t know the vehicle but online seems to show that the port is located under the dash to the left of the steering column

Был ли этот ответ полезен?

Оценка 0

Комментарии:

I haven't, yet. No check engine light or anything. Might jump the port tomorrow (have read multiple places saying this will show me on the dash via a series of flashes).

из

No codes. Did some local driving today. Engine seems to run fine. It seems more like an issue with the transmission not downshifting when it should...

из

@brandon_k

Maybe check the easy things first. Apologies if you've already done so.

Have you checked the transmission fluid and filter to see that it is correct level, clean and doesn't smell burnt etc? Online it seems that changing the fluid seems to vary between 30,000 and 60,000 miles, for your year model, depending on how the vehicle is used

из

will have to check tomorrow or the day after. Was fairly late when I got home and drove it.

из

Truck shows no codes. Haven't checked/changed filter. Trans pan has rear edge on crossmember so can't get to the bolts. Fluid seems fine though.

из

Показать 2 больше комментариев

Добавить комментарий

Добавьте свой ответ

brandon k будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 2

За последние 30 дней: 6

За всё время: 51