Перейти к основному содержанию

The smaller of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

151вопросов Показать все

MacBook Air Battery not even recognized after being Recalibrated

I did this exact process:


When I returned to the laptop after the full 5+ hour post-0% power drain (second to last step), the battery is ABSOLUTELY NOT RECOGNIZED.  It’s as though it's not even there. I did the recalibration because I was only getting 3-4 hours on a charge. Before this CoconutBattery showed ~4000 Amps out of the OG 4600 available, and the cycle count was only ~690. CoconutBattery now shows empty fields where text should be, as though there is no battery to discuss???  "Show Battery In Menu" (System Preferences / Energy Saver) literally will not work - you check it and it un-checks itself.

I tried to reset the PRAM and it acted normal ONCE and charged up to 92% and CoconutBattery showed that normal 4000 amp capability, and about 690 cycles. But then I closed it for a few hours and when I reopened it the problem was back and now worse than ever.  SMC reset could only be tried with power cable in (did not help), further PRAM reset did nothing, Mag-Safe power cable always has the orange light, and if power cable is detached the computer dies immediately.  Disk First Aid did nothing and says it’s “All Fine” (NOT).

Starting from an external drive shows the same problem - no sign of the battery even when running from an external boot attached via USB (External Start Up Disk).

I even reinstalled the whole operating system…. No change.


Its as though that extra "5 hours of extra drain time" after it hits zero % has DAMAGED the laptop’s ability to even recognize what should be a perfectly good battery!

p.s. If I open About This Mac / System Report, it says this about the battery:
Battery Information:

  Model Information:
Serial Number: D86812700PLDKRQCB
Manufacturer: SMP
Device Name: bq20z451
Pack Lot Code: 0
PCB Lot Code: 0
Firmware Version: 406
Hardware Revision: 000a
Cell Revision: 173

Charge Information:
Charge Remaining (mAh): 1958
Fully Charged: No
Charging: No
Full Charge Capacity (mAh): 4043

Health Information:
Cycle Count: 682
Condition: Normal
Battery Installed: Yes
Amperage (mA): 0
Voltage (mV): 7644

p.s. very similar problems to this FixIt post, but I am not skilled enough to open the case:
MacBook not recognizing battery, not even in coconutbattery

Block Image

Block Image

Block Image

Block Image

Update (02/17/2022)

UPDATE, Semi-Repair, Weird Residual Problems….
Took it to an Apple Repair facility. We replaced the battery completely as many above suggested. The small circuit board where the Mag-Safe plugs in (the “DMC”?) was also replaced. The computer started right up, and holds a charge.

For some insane reason, while the battery now works somewhat properly, both the System Report AND Coconut Battery are ONLY showing the information from The Old Dead Battery, and neither will update to the NEW Battery Information under any circumstances! Tried resetting PRAM, SMC etc. Incredibly weird. We even tried TWO (a second) New Batteries - same result.

To make matters Even More Weird, we ran the “MRI” panel of tests from Apple, and overall everything checks out great…. Except that Same INCORRECT Battery Cycle Count and the mAh Charge Numbers all of which STILL are showing the number from the Old Dead Battery even though the Serial Number of the New Battery and other information is showing “properly”…..?!??!?

Spoke to a half dozen local Apple technicians as well as several Apple Care Senior (Tier 2) folk, and literally NO ONE has any idea why this is happening nor have any of them seen this set of issues before.

The actual repair facility tech who helped me swap the battery and replaced the DMC (?) suggested that the issue might be that the batteries are newer tech than the High Sierra operating system, and as such H.S. is not able to send / receive the correct read out and updated information, but that was pure speculation.

SO…. the current situation is….
1. Good new battery holding a charge & computer can start up properly.
2. Battery STILL discharging too fast yielding maybe 3-4 hours even though its a New Battery.
3. Replaced the small chip / board where the Mag-Safe plugs in as well (the DMC ??) so that has been eliminated as a potential cause of the problems.
4. System Profiler shows an active battery but yields incorrect information from Old Battery.
5. CoconutBattery has the same problem = Shows a battery but shows Old Information.
6. Apple MRI Test shows a battery with a completely different Serial Number (the actual new battery), but ALSO shows the INCORRECT Cycle Count and Amperage from the Old Battery.

Anyone have any thoughts on this weirdness??

A BIG Thank You to everyone here trying to help figure this out!

Attaching Screen Shots of the Current New Battery
(Cycle Count should be lower than 5)
— System Report screen
— CoconutBattery screen
— MRI battery test results screen

Block Image

Block Image

Block Image

Fresh Coconut Battery screenshot - Feb 18, 4pm

Block Image

Update (02/15/2022)

@danj - Thank you again for all your attention to this matter - I SERIOUSLY appreciate it. We will try everything you have suggested including an inspection and possible replacement of the logic board. The reason I find it hard to believe it is a battery issue is that it is the exact same problem - worsening - that we have now seen on 3 different batteries, two of which were supposedly new. Exact same issue. We are now ordering a 4th "New" battery as well. If I did not know better I would even suggest a "short" somewhere, except that literally every other function of the laptop works perfectly (all programs) ....???

For the record, I have two (2) major modifications on this laptop which were never a problem and ran for 6 - 12 months flawlessly before these weird battery issues ever started:

1 - The actual keyboard (whole top panel) was replaced. Years of use made several keys stop working, so a certified Apple technician replaced the whole top panel / keyboard with a brand new one. HOWEVER, as this happened in New Zealand, the panel & keyboard were European English style and slightly different key placements (but still QWERTY), and not exact USA placements. This never seemed to make a difference in the ensuing year following (I just had to slightly adjust my typing style).

2 - I upgraded the 500 Gb flash drive to a 1 Tb flash drive. The exact flash drive plus the necessary adapter was chosen by the same Apple Technician who installed the keyboard panel. The only immediate change this caused was a double-start process where the laptop would start, the screen would remain blank with slight backlighting, and then it would restart again on its own and thereafter start up properly (i.e. TWO apple chimes spaced about a minute apart). To get around the double chime start-up, after a great deal of research I used these two Terminal commands to Disable Hibernation:

---> "sudo pmset standby 0"

---> "sudo pmset autopoweroff 0"

That resulted in a proper single-chime startup. This has been the case for about 9 months without a problem. In light of the current problems and wanting to eliminate possible contributors, I just recently reset the 0 to 1, activating hibernation again:

---> "sudo pmset standby 1"

---> "sudo pmset autopoweroff 1"

Lastly, I downloaded an app to try out called "CleanMyMac X" and tried it out just before I did the first infamous "recalibration" (the recalibration which appeared to start the current mess). In that app the only relevant item was Launch Agent control, and I disabled all Launch Agents that I did not recognize as necessary programs I used. After the new problems started I uninstalled "CleanMyMac X" and scoured the Library etc for orphaned parts of the app (there were several) and deleted them. I then did a full reinstall of the whole OS X High Sierra, theoretically resetting the Launch Agents native to OS X.

For whatever it is worth, prior to ALL of this - and especially BEFORE I did that infamous initial "recalibration" - I made a rock-solid clone of my whole drive, so if I need to completely wipe the SSD and replace all the software with the clean clone - Given That This Is In ANY Way a Software Matter (???) - I can do that.

Again, I seriously appreciate everyone's help and suggestions.

Update (02/22/2022)

So some Good News as we approach a Solution. Today the local technician and I tried several things:

1. We found a battery that seems better than the one we started with.

2. We did the HARD Reset on the SMC (as it was called by DanJ explaining it) where we removed the battery completely (no power cable) and held down the POWER key for about 15 seconds.

3. When we plugged the "better" battery in again, FINALLY the System Report / Power / Battery MATCHED the information from CoconutBattery for the first time since this fiasco started. The NEW Cycle Count showed 233 on both, the Serial Number of the battery finally matched on both, when the charging cable was plugged in it showed as active with the incoming mA details, etc.

So thus far a HUGE improvement. I took the "better performing" laptop home and plugged it in, charged it to 100% + about 3 hours. It charged to 100% and I am now writing this on battery-only.

Remaining Issues:

A. The battery is still draining WAY too fast. In the time it took me to check email (no replies) and write this 3-Part set of comments it has dropped by 12%. That seems ridiculously too fast.

FYI my brightness on the screen is set to about 50%. As for "Apps Using Significant Energy" from the battery icon drop-down menu, it is showing "Spotlight.app" and Chrome are the only culprits.

It could be noted that the Discharge rate / amount showing in the System Report / Power is saying the battery is draining at:

" Amperage (mA): -1507"

--> Is that way too fast / to much?

B. I notice two variation of "waking." One is when the clamshell is OPEN and I let it go to sleep. Wake up from that is near-instantaneous and proper. HOWEVER, when I close the clamshell and then re-open it, it just gives me a backlit blank grey screen and stays there. I had to do a manual shutdown (hold down the power button) and restart. It restarted properly and efficiently.


1. I am guessing the open-clamshell WAKE and closed clamshell WAKE are two different Sleep / Hibernation / Etc settings. Is that correct?

2. Being quite comfortable using Terminal, can anyone suggest changes I can make to the settings that would cause the closed clamshell being opened "Wake" to occur faster OR when closed to go into "less deep" of a sleep, thereby imitating and open clamshell sleep+wake?

As I understand it, these states are not exactly the same.

I should add that the 1 Tb SSD wants a "double-startup" process that had me Disable Hibernation completely. I re-enabled it when these problems started just to normalize things.

As always I seriously appreciate any and all help and thank you all in advance.

NEW System Report & CoconutBattery screenshots….

Block Image

Block Image

Update (02/23/2022)

I want to post this here as an ADDITIONAL ANSWER so please leave this here for future readers because it is about how we SOLVED the Main Issue of this post described in the Title / First Paragraphs (even though we have additional remaining issues).

Regarding the issue of the Battery Not Being Recognized and Not Charging At All and No Battery Indicator Icon At All….

We did the HARD Reset on the SMC where we removed the battery completely (no power cable) and held down the POWER key for about 80 seconds (a full minute and then some, timed). We then reinserted (reattached) the battery, closed the case, plugged in the power cable and restarted the laptop.

+THE RESULT of the Hard Reset on the SMC+
FINALLY the System Report / Power / Battery MATCHED the information from CoconutBattery for the first time since this fiasco started. The NEW Cycle Count showed the same number on both, the Serial Number of the battery finally matched on both, when the charging cable was plugged in it showed as active with the incoming mA details, etc. A HUGE improvement.

Since then, the battery now charges to a full 100%, the Battery Indicator Icon shows properly, and all these aspects maintain regardless of which battery is inserted, and regardless of Shut Downs / Restarts / Sleep / Hibernation / Etc.

TO REITERATE for anyone else seeing the OG problem described in the Beginning / Top of this post, try a HARD RESET of your SMC as per what is written under “+SOLUTION+” above.

Note that this did not solve the latter issue of the excessively fast battery drain.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0

12 Комментариев:

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question

Sadly, it does look like the battery has failed on you. with the added data CoconutBattery offers we should be able to tell.


@danj -

Hi Dan. Here are several images both from Coconut as well as a shot of the System Report now showing that it thinks there is No Battery At All..... ?!?!?



@ajotr - Ah! You need to do a hard reset. Disconnect the battery and with the nothing connected, press and hold the power button for a good 15 secs, that fully drains any power still within the logic board. Now carefully plug in the MagSafe charger (not the battery). Your system should spontaneously startup. if you open CoconutBattery the values should be gone! Now carefully shut down your system again and plug in your battery. Now give it a few minutes as the SMC needs to cycle to past the data to the OS and then onward to CoconetBattery it should now have the new batteries data.


Hi Dan. I will ask the technician tomorrow if he tried the "Hard Reset" as you described, but in the mean time..... its now WORSE.

After only Two (2) Hours the battery completely drained while the laptop was Open / In Use for one (1) hour, and then Closed / Asleep for one (1) hour.... and now the New Battery is now not showing up at all.... just like the original problem. Back again. ARRRGH.

Thoughts? Still the Hard Reset? Or is this laptop just flat out DYING?

Again - side note - EVERY PROGRAM on the laptop runs perfectly fine. This is 100% only a battery-charge issue, and is obviously not connected to whether or not the actual battery is new.


@ajotr - Post a fresh snapshot of CoconutBattery so I can see it.

At this point the logic board charging logic is likely damaged, this can happen when a knockoff charger is used which damages things! I haven't seen one damaged like yours so that has me scratching my head. In any case the logic board will need a through inspection for corrosion and/or a liquid spill around the Intersil 625 9AHRTZ and SMSC 1704-2 chips as seen in Step11 in this MacBook Air 11" Mid 2013 Teardown


Показать 7 больше комментариев

Добавить комментарий

1 ответ

Well, the bad news is the batteries micro-controller has failed, you’ll need to get a new battery.

Is this the original battery or a replacement?

Here’s the needed part MacBook Air 11" (Mid 2011-Early 2015) Battery and the needed guide to put it in MacBook Air 11" Mid 2013 Battery Replacement

MacBook Air 11" (Mid 2011-Early 2015) Battery Изображение


MacBook Air 11" (Mid 2011-Early 2015) Battery


Был ли этот ответ полезен?

Оценка 0

10 Комментариев:

Well darn. Previously the battery was showing 4000 amps / 690 cycles, but it was still draining after 4 hours. The thing that tipped it into this situation was when I just recently "Recalibrated" the battery and let it drain to 0% followed by 6 hours of no charging. Any idea why that tipped it over the edge into its current unrecognized situation? Or why it would "go normal" for an hour and then relapse into this current "Unrecognized" state?

Is there ANY way to reset this without replacing the battery?

Thank you in advance for your help.

p.s. This is a replacement battery that I got back in 2018 from a certified Apple Repair Facility.


@ajotr - Its not worth trying to fix the battery as you'll need to find a second battery to steal the Micro-controller chip and then replace it which on a battery is tricky!

I can't tell you why the Micro-controller died there maybe something else going wrong within the battery that burnt the chip. Sorry


MCU failure is very rare. Seems it could be a connecter failure. You need both SMBus lines and ground (which you're very likely to have) to communicate with the battery controller.


@ffixitwell Using a metal tool shorting across the batteries connector has killed a few. Even still the Micro-controller being used in these batteries do seem to fail at a higher rate.

Replacing the battery solves the issue so it's not a data line issue from the battery to the SMC logic on the logic board. You mean SMBUS_SMC right?


SMBus is the bus standard. I don't actually know whether the 2013 has the battery management MCU in the battery itself. It's old enough I would think so.


Показать 5 больше комментариев

Добавить комментарий

Добавьте свой ответ

AJotr будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 3

За последние 30 дней: 21

За всё время: 1,306