Перейти к основному содержанию

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1203вопросов Показать все

Ethernet cable does not snap in the jack

When I plug an ethernet cable into the jack, it will go in but the little tab will not lock into place. What is the problem?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
3 Комментариев

have you checked the plug?

does it happen with more than one?

из

Yes, its all clear and its happens every time. even with different cables

из

The "top" of the macbook jack is not tall enough at the outer (opposite the contacts) end. So, the latching tab can be slightly depressed downward by the aluminum, causing the essential hook on the plug to not fully mate with the hook in the jack. The solution is to file down the top side of the latch until the keeper will engage as expected. A more drastic method that would work with all cables would be to remove a notch of aluminum from the top of the case. Ugly, but effective.

из

Добавить комментарий

6 Ответов

Выбранное решение

A question for your question... Has your port exhibited this behaviour since new, or is this a recent development?

**Edit**

Since this problem started after you purchased the machine, it was most likely caused by something getting into the port, or by a physical deformity of the case or connector housing itself. If you can't see anything stuck inside the port, look to see if it is bent/broken anywhere around the edge (mainly right at the top where the cable's clip connects).

If cables aren't fitting into the port anymore, my workaround would be to make sure you have a cable with lots of slack, and remove the clip that holds it in place. Generally if there is no tension, an ethernet cable will stay in the port without the clip.

Был ли этот ответ полезен?

Оценка 2

2 Комментариев:

I've had it since 2006 and i think it was working good then, I can't remember when it started but it is not recent - maybe 1 or 2 years ago.

из

Mine is the same. I am constantly crawling under the desk to reinstall it. Tried a new cable and same thing,

из

Добавить комментарий
Наиболее полезный ответ

Hi! Sometimes I've found that the little plastic tab on the top of the connector goes "soft" and does not have enough bounce to get high enough to latch inside the port. If you carefully pull that plastic strip upward, making sure not to break it off, this can re-establish its position so that hopefully when you plug it in again, it will rest in the proper position to click inside the port. Of course, if you've tried multiple cables with the same result, it may not be this at all and may be something inside the port.

Был ли этот ответ полезен?

Оценка 3

2 Комментариев:

No, its definitely the jack as I have been using brand new cables.

из

I have this issue periodically. Seems to only happen with Lutron jacks. There is a small block at the rear of the jack. It forces the rj connector up into the jack pins. It will then click into place. It's a very secure connection that requires twice the force of an ordinary connection.

из

Добавить комментарий

Might want to check the metal wire contacts inside the jack to make sure each one is in its proper channel. I know with a phone jack, I've had those metal contacts get bent and keep the phone plug from going in properly.

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

Plug may be deformed around, or have something in, the recess for the tang.

N.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

To me, It looks perfectly normal..

из

Добавить комментарий

It happens with me too. It's just unproperly shaped cable or port. Seeing that you're getting the same problem with different cables, it indicates a problem in your jack's shape.

Try inserting modeling clay in the port and comparing the shape that comes out with the shape of the connector. Then maybe you could remove the excess part.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

That seem kinda dangerous dont you think..

из

Добавить комментарий

I am having the same issue.

I bought a new Cat 6 Ethernet cable. Cable internet is 300Mbit, but speed tests have me maxing out at 100Mbit -- that was the limitation for Cat-5, but Cat 6 should go up to 1Gbit with this computer. This lead me to troubleshooting the issue, and one glaring issue that may be causing this is that the new Cat 6 goes in, but does not click into my Macbook 2012 Pro 13" or my wife's. It does click on each end of the cable into my modem/router.

I tried my old Cat 5 cable in every port and each end of it always clicks into every device, even the Macbooks.

I have deduced that there is something wrong with the shape of the new Cat 6 cable I have. Comparing the dimensions and contours side to side, and can not see any different in their shape or side that tells me why the Cat 6 won't plug in.
It was only $5 for a 10 foot, so it is a cheap cable.

I read that if there are any wiring/crimping issues, the fewer viable wires would cause speed to go down to 100Mbit. So that may be an issue to look into as well.

Anyone else have issues with some Ethernet connectors not fitting into Macbooks? Are they all the same exact shape/form factor?

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

Hey guys just so you know I'm at cable technician if it is your cable wire that first person is correct you just have to bend the plastic tab outwards so that it clicks in again. If it's the port they all so very cheap and extremely easy to change everything's color coded all you need is a Phillips and a small flat head to punch the wires into the new port.

из

Добавить комментарий

Добавьте свой ответ

AussieMac будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 9

За последние 7 дней: 78

За последние 30 дней: 322

За всё время: 36,061