Перейти к основному содержанию

Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

794вопросов Показать все

Disk Utility unable to erase or partition SSD Drive

Hello everyone, I had a drive failure on my Mac and learned it had been corrupted via disk utility. After attempting to fix this it now seems there is no startup volume.

I tried restoring from my backup but disk utility could not restore from my backup and a pop up notice suggested the drive be erased first. It didn’t appear to work but after starting up again the drive appeared erased. However, there’s no startup volume shown.

I can see the drive name but the partition option is grayed out. When I try the erase option again to rename the drive it keeps saying it failed. I’ve also tried a few terminal commands to no avail.

Any idea as to how I can get through this?

Thank you, I look forward to your replies.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Sounds like you have a OS mis-match issue here!

Your system by default uses HFS+ file system you need to limit the OS to Sierra 10.12.x otherwise you can create OS & Firmware confusion!

Yes, this system can support APFS when you upgrade from Sierra to High Sierra but I’ll warn you HS was an experiment! Apple updated the file system and OS with better versions of APFS but you system really can’t support the newer OS’s.

So what I suspect here is this disk was setup from another system running a newer macOS release (APFS) which is messing you up. Your MacBook’s firmware was not upgraded with the need version so it won’t work properly.

Был ли этот ответ полезен?

Оценка 0

16 Комментариев:

Dan, thanks for replying it’s appreciated. I’ve been running High Sierra for about 3 years now with no issues until now. Currently using an SSD drive which seemed to have failed.

Here’s an update on the issue: I took out the drive and placed it into an enclosure and was able to connect via USB and format it with a name, etc. I’m not familiar with much of the tech specifications but the install instructions from OWC (where I purchased the drive a few years ago) suggested that APFS be selected and not Mac Journaled.

Then I was able to install HS again via internet recovery and am currently trying to retrieve some lost files. I’m using a recovery software and have found some files but for some reason Adobe Illustrator files aren’t showing up (I’m in the graphic design industry).

Hopefully I can recover my files soon.

At this point I may just go back to a disk drive or keep this same SSD. I’m just holding off for a few more months before a new(er) Mac purchase after the Holidays.

So when I reformat again, do I go with APFS or Mac Journaled?

Is that how the HFS+ is established?

I’ll also most likely revert back to Sierra 10.12.x per your advice.

Thanks again, I look forward to hearing back.

из

Some clearity here would help.

Why do you think the SSD drive has failed?

Is this the same drive you connected via USB?

If yes then it sounds like you may have over-written some of your files your files. You do you have an external back-up drive, don't you??? At least for your Adobe files???

Oh and you just posted as an "Answer" when you were asking more questions.

из

@zerimar3 - The OWC SSD requires APFS per their documentation. Frankly, SSD’s work better with APFS, yet spinning iron HDD’s work better with HFS+

из

@mike I was working on a project the other night when the computer froze. On restart it would get stuck. Tried logging in through safe mode and was unable to. Did a PRAM reset and got back in. Everything was extremely slow but managed to close out programs and got stuck on restart again. Various attempts at using disk utility to repair which did not work.

Ultimately got a blinking folder and then just a white screen. Tried for hours as everything was moving extremely slow. Slow because after nearly an hour of the white screen the login would show up but not let me through.

And yes, the same drive that failed is now connected via USB and I’m trying to recover files. After connecting with USB it was able to be reformatted/partitioned.

But now I’m curious to know if it was a the drive or the SATA cable that failed. Thoughts?

Also, I do have a back up as I wrote in my initial post but not for the last 5 days. Thanks what I’m trying to recover.

@Dan: noted - regarding APFS and HFS+. I did follow the documentation, thank you.

из

@zerimar3

Yes you did mention your backup.

@Dan could help you better with the cable.

Data recovery rule #1 - don't do anything to drive before attempting recovery as files may be over written.

This is what I am concerned about "After connecting with USB it was able to be reformatted/partitioned." That action can over write files permanently.

Ideally you would want to connect the drive to another working computer and just pull your files off or use data recovery software if needed.

из

Показать 11 больше комментариев

Добавить комментарий

If you have any files you want to save, copy them to another storage device.

Open the Disk Utility app on your Mac using one of the following methods, depending on the type of disk or volume you want to erase:

If you want to erase your startup disk: Start up your computer in macOS Recovery, then choose Disk Utility in the Recovery app. To learn how to start up your computer in macOS Recovery, see Intro to macOS Recovery.

Note: If you want to get your Mac ready to trade in, sell or give away, and your computer is a Mac with Apple silicon or an Intel-based Mac with an Apple T2 Security Chip, use Erase Assistant.

If you want to erase any other type of storage device: Double-click Disk Utility in the /Applications/Utility folder.

Choose View > Show All Devices.

In the sidebar, select the storage device you want to erase, then click the Erase button.

Click the Scheme pop-up menu, then choose GUID Partition Map.

If the Scheme pop-up menu isn’t available, make sure you selected the storage device you want to erase — it’s at the top of the hierarchy.

Click the Format pop-up menu, then choose a file system format.

Enter a name.

(Optional) If available, click Security Options, use the slider to choose how many times to write over the erased data, then click OK.

Secure erase options are available only for some types of storage devices. If the Security Options button is not available, Disk Utility cannot perform a secure erase on the storage device.

Click Erase, then click Done.

This May Help,
Peter

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

@antoniosgrift Thanks for the info and the very helpful tips. I appreciate your straightforward communication. I’ve gotten most of my files back but not all. Still moving forward.

I’m going to try more of what you suggested later this evening as I try to get my machine back to where it was from a fresh start. Thanks again for the help it’s greatly appreciated.

из

Добавить комментарий

Добавьте свой ответ

zerimar3 будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 1

За последние 7 дней: 7

За последние 30 дней: 14

За всё время: 593