Перейти к основному содержанию

Hard Drive input/output error

Hi everyone

The laptop is a MacBook Pro 15", 2.16 GHz Core Duo, Model A1150.

It has been given to me without hard drive in it and I have no clue about what it went through.

The laptop works perfectly booting from Ubuntu cd.

I have two hard drives to try with, both “Western Digital” and both 160 gb:

Hard Drive 1: WD1600BEKT, brand new guaranteed by the ebay seller to be specifically compatible with my MacBook Pro A1150;

Hard Drive 2: WD1600BEVT, pretty old.

I've installed both drives (one per time obviously) in a Dell Inspiron 1525, installed Ubuntu OS and both drives worked perfectly.

Now I install the drives in the MacBook, and every time I do so I call one SMC reset and three PRAM resets.

50% of the times the drive is detected and a faulty Ubuntu OS is loaded.

50% of the times the drive is not seen at all and I get the question mark folder.

Same goes when I boot the pc from Ubuntu cd, 50% of the times the hard drive is shown on “Disks” application, 50% it doesn't appear.

When “Disks” shows the hard drive, still the hard drive is not really accessible, only one time out of dozens SMART data was available.

Time to install Ubuntu, or at least try:

50% of the times the hard drive is not detected and installation cannot be initiated;

50% of the times the hard drive is detected, the installation seems to be started but after few seconds I get “Input/output error during read on /dev/sda”

I've replaced the hard drive cable and after that I went through the exact same experiences.

I've set the hard drives jumper setting to SSC first, RPS after and still no luck.

Any help will be highly appreciated.

Thanks in advance

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

по рейтингу 0
Добавить комментарий

PC Laptop Batteries

An easy fix for a big power boost.

Купить сейчас

PC Laptop Batteries

An easy fix for a big power boost.

Купить сейчас

6 Ответов

Выбранное решение

OK lets first look at the specs of your MacBook Pro:

Now lets look at the spec sheets for the two HD's you have:

Now looking at the MacBook Standard Hard Drive section we see the system can only support a SATA I (1.5 Gb/s) drive. Now looking at the Scorpio Black sheet we see the HD Interface is SATA II (3.0 Gb/s) and if we look at the Scorpio Blue we see it also runs at SATA II (3.0 Gb/s).

Both of these drive will not work reliably in your system - Sorry ;-{

OK, lets see if we can find a drive that will work. What if we can also increase the performance as well here (better than either of the two drives you listed).

I happen to like the Seagate SSHD units we find them very reliable and offer better performance than a straight HD. Here's the link to explain about the drives: Seagate SSHD and here is the link to the spec sheet: Seagate Laptop SSHD Spec sheet. Now looking at this sheet location this line SATA Transfer Rates Supported (Gb/s) Here we can see the following: 6.0/3.0/1.5. So this drive unlike the WD is auto SATA speed sensing matching to the systems SATA ports I/O speed. Which makes it a very workable drive for you!

Two more points here:

You still need to make sure your systems firmware is upto date. Follow this Apple TN on how to check and update: EFI and SMC firmware updates for Intel-based Macs

I do strongly recommend getting a FireWire external HD case to hold one of your Western Digital drives so you have a backup drive. If you can't return it. In any case if you have anything important on it you do want to wipe if before returning the drive.

Был ли этот ответ полезен?

по рейтингу 4


Thank you Dan for the prompt reply.

Aren't SATA drives supposed to be backward compatible?

Also you didn't comment on the jumper setting which I set to SSD as Mayer recommends in this post:

New hard drive input/output error

for the purpose to “set it down to 1.5 GB”, here is the Western Digital page:

WD SATA Mobile Hard Drive Jumper Settings.

In any case, before we all spend more time on it and I spend more money, do you think there is any chance that the problem is a faulty logic board?


Are SATA drives backwardly compatible, not really. As you have discovered some have jumpers. Many newer drives don't offer a means to run at the slower SATA ports of many systems. Some drives have auto sense SATA ports which match up (as in Seagate's SSHD). Now looking at being comparable a slower SATA drive will work in a newer system which has a faster SATA port the standard was written to be backward compatible this way. As the thought was the cost of a HD was too expensive to throw away when you got a new system.


You may want to double check with WD if the jumper will work on your drive (have them send you a few). I've encountered drives the jumper option does not work! I think some HD suppliers have killed it off on their newer models of drives. You can also encounter an issue with some of the jumpers as there are a few different headers and each need different jumper.


I would get an external FireWire HD case to place the HD into to prep up. If you find the drive is stable there you know the issue is the more likely the SATA port speed is not right when you put it internally in the system. As to being a logic board issue I doubt it. You may have a bad SATA cable though.


Happy new year to everyone!

I've been busy for a while applying your recommendations to my Mac.

New items:

- Snow Leopard installation DVD

- Hitachi hard drive HTS541680J9SA00, which appears to be 1.5 Gb/s.

I connect the drive internally and boot from DVD: disk utility, disk erase, I get input/output error.

I connect the drive externally through usb and install Snow Leopard successfully.

Now my Mac works great.

Check EFI and SMC firmware: they are already up to date.

Now I connect the drive internally:

sometimes nothing happens, sometimes Apple logo appears and nothing more, sometimes SL boots successfully.

When it boots right, it is not so brilliant like it is externally and after a little while it freezes, leaving me no other choice than holding the power button.

A little curiosity: when booted from DVD, disk utility says that connection bus is “serial ATA 2”; when booted from internal drive it says “serial ATA” only.

I had the same result with both sata cables and plenty of SMC an PRAM resets.


Показать 1 больше комментариев

Добавить комментарий

The first thing I would do is to stop trying to use systems other than Macs. Get a retail version of OS X 10.6 and boot from it. Use Disk Utilities to format the drives GUID so the Mac can read and write to them, Format as Apple Extended. I would also zero out the drives at this time to map out eliminate any bad block or sectors. Now install the operating system and then download and run the updates to 10.6.8. If all this works well you can now download 10.7 and update it to 10.7.5.

Был ли этот ответ полезен?

по рейтингу 2


Thank you mayer for the prompt reply.

Are you saying that I can give a go to OS X keeping the hardware the way it is now?

Also I said above:

“50% of the times the drive is not seen at all and I get the question mark folder”

Should we blame Ubuntu for that too?


Добавить комментарий

A correction for Mayer: A Core Duo MBP, like all 32-bit Mac/Intel systems, has 10.6.8 as its OS X ceiling.

Claudio, you should be able to install Ubuntu (or other Linux distributions) as a boot OS, although OS X 10.6/Snow Leopard is a lot easier to get and install. The key thing to remember when installing a Linux distro is that Macintoshes are not generic Wintel boxes, no matter what outsiders believe. Even when the chipsets and component numbers match the ones from Intel and component manufacturers, Apple often does special firmware. And Apple is a big enough customer that they often force the OEMs to modify the stock components to perform to Apple's specifications.

TL; DR version? Don't expect a Linux distro installed on a non-Apple machine to boot an Apple machine; non-Mac installs are unlikely to include the drivers Mac hardware will need. A better strategy is to download a Linux install disk image compatible with your Mac hardware, burn it to an optical disk, boot off the disk and then install. Another technique is to install OSX first, then use Apple's BootCamp utility to create a Linux partition for dual booting.

The Ubuntu site has a tutorial for installation on a MacBook Pro1,1 (Core Duo). Their recommendation, like mine, assumes that you've already installed OS X and all the firmware updates before attempting the Linux install.

Был ли этот ответ полезен?

по рейтингу 2


Adlerpe - Good points on the Ubuntu install issues! Agreed, you really need to run it via BootCamp.


Добавить комментарий

Problems are wrong drives.

The WD1600BEKT is a SATA II drive and you have a SATA I box you're trying to use it on. If it clames to automagically detect and adjust throughput speed it's not doing it (most SATA revs are backward compatible one version -looks like you've found a couple of exceptions) if possible, and you know or find out how, you'd have to manually jumper them down to SATA I. I don't know what jumpers to use so I have no idea if you're in the ball park.

The same thing seems to be going on with the WD1600BEVT. It too appears to be a SATA II drive.

Any OS uses VMEM and SWAP files - if there's problems accessing the drive then freezing and errors would be a normal result.

If this answer is acceptable please remember to return and mark it accepted.

Был ли этот ответ полезен?

по рейтингу 1


Thank you machead3 for the prompt reply.

I did set the jumper as I said on the original question, I then explained it further to Dan (here above).

Also I'd be glad to hear your opinion about the same question I asked Dan:

Is there any chance that the problem is a faulty logic board?


Nothing more or other than what Dan has already covered. Possible discussion with a vendor may allow you some economic relief, or to exchange the drive for a SATA I (if they have any in old "new" in stock… I don't know where you could obtain a new SATA I drive).


Добавить комментарий

You can use SATA 3 drives in a SATA 1 or SATA 2 machine, ignore advice claiming otherwise. You can plug a top of the line new SATA 3 SSD into an old piece of junk A1150 and it will function just fine from modern Crucial SSDs to Seagate 1 TB SSHDs to 320 GB WD blacks. I do it everyday. I would be bankrupt or too busy fighting chargebacks to post here if this were not possible.

Your issue is most likely related to one of the following.

a) Those drives are developing bad sectors. Can you even buy 160 GB drives anymore? How old is that thing?! Old enough to be DEAD is the right answer. And for !&&*'s sake, you bought it on EBAY!!! and they TOLD you it was new... so it must be, right? ;) eBay is the WORST place to unintentionally buy BROKEN CRAP!!!

hard drives in laptops have an average shelf life of 3 years before failing or starting to kick the bucket. ANYTHING PRODUCED that is 160 GB is already outside that timeframe.

b) Your X1600 chipset is failing. They are all dead by now, there are no new ones so I cannot even recommend you TRY replacing the GPU on that. Even if you were able to find a new GPU for that thing, the Samsung VRAM will die while you try to replace it, so absolutely no point to even try.

c) The drive cable is bad. Highly unlikely, the only ones that die without reason are the 13" Unibody cables.

Do this.

Buy a NEW drive from NEWEGG, NOT EBAY!!!!!!!! SATA, 2.5" - this is all that matters. Use a WORKING MACHINE to put 10.6 snow leopard on this drive - any other Macbook Pro from 2006 to 2011 will work fine for this(but core i models will only boot from 10.6.8, not 10.6.3). Then place that drive into your A1150.

If it works, you know the issue was you have bad installation media or a bad drive.

if this does not work, it's time to toss that A1150 in the bin. But really, if ANY X1600 based machine isn't at least a little dead by now, I will be very surprised. Those chipsets were junk when they were new, and do keep in mind that at this point in time, they are nine years old.

Был ли этот ответ полезен?

по рейтингу 1


The drive I had from ebay (WD1600BEKT) was definitely new, SMART Power_On_Hours is now 3 and no bad sectors at all; you still may have a point about the shelf life factor, but It works perfectly in other pcs.

About the Hitachi HTS541680J9SA00: I bought it brand new in 2008 and since then I used it exclusively as a external backup, meaning no shelf time and very little usage as SMART proves (and no bad sectors).

About my Junk A1150: I just happened to have it on my hands, I'm enjoying the challenge and even if I fail it will be a successful learning story.


Buy a new drive from newegg, put snow leopard on it, and report back. Do you have another mac to help you with this process?


Sorry Louis but I really don't understand.

You said that any drive would do, any drive but the three different drives I have, and that's because all of these drives are corrupted.

SMART data for these drives shows no problems.

Drives work great in other pcs, they load the OS and the pc is just brilliant.

The A1150 itself works wonderfully booted from the drive connected through usb.

Now I'd buy a new drive if you were proposing it as a final solution.

I definitely wouldn't spend another 50 quid just for a test and then finding myself with one more redundant drive.

I understand you run a workshop, but here is just me and two laptops and a half.

I don't mean to be polemical, I really appreciate your help, I'm just saying things the way they are.

To fully answer your question: no, unfortunately I don't have another mac.


@Louis - This system can only support a SATA I drive or a drive that is able to auto baud to 1.5 Gb/s. Sure a SSD could be used but the OP wants a HD likely because he wants the space a HD offers and the cost of a SSD is higher and has limited storage.


Добавить комментарий

I'm really grateful for the help you guys gave me and for the time you spent for me.

I did spend a lot of time and some money to apply what you taught me.

Now the pc is still not working and all of this will turn into a big wasting of time if you guys don't help me throughout the all process.

An unfinished thread is also very disappointing for web users landing in the page.

I made comments under Dan reply, which seems to be the only way to continue the thread.

Now I'm answering my own question in a desperate attempt to get your attention.


Был ли этот ответ полезен?

по рейтингу 0


So you got the HD to work in an external case? Prepped and OS-X installed?


That's right, as I explained commenting your answer above.

I assumed from your instructions (please correct me if I'm wrong) that once the drive works externally it can just be transferred internally.


And you are using the correct drive here: SATA I (1.5 Gb/s) drive, not anything faster correct? If so then your systems SATA cable is bad or the connector is damaged on the logic board.


Drive is Hitachi HTS541680J9SA00, when I google it all I see is 1.5 Gb/s.

I've tried another tested refurbished SATA cable and nothing changes.

I think at this point we all agree that the problem is the logic board.

I'm considering to buy an optical bay hard drive caddy, do you think it could work?


I've had some bad SATA cables so I would try one more (new Vs used) to be sure. If it fails then the connector on the logic board is likely bad. Take a good magnifier and look carefully at the pins and solder joints. Anything bent or discolored? If the drive logic is bad then you won't gain anything with the HD caddy for the optical drive. Also this systems optical drive is not SATA its PATA so you will get even slower throughput. It's been awhile, I don't even think it will boot up with an HD in the caddy because of the conversion logic (PATA to SATA for the HD) in the caddy.


Показать 2 больше комментариев

Добавить комментарий

Добавьте свой ответ

Claudio будет вечно благодарен.
Просмотр статистики:

За 24 часа: 0

За 7 дней: 7

За 30 дней: 50

За всё время: 4,020