Перейти к основному содержанию

The Asus MeMO Pad 10 features a vibrant IPS display with a 1280 x 800 resolution.

19вопросов Показать все

My Tablet wont turn on, any ideas?


I have a Asus Memo Pad Smart K001 that don’t turn on.

I when I connect it to charge it shows green battery charging but after 3 times image charging it stops and the screen got black and never turn on, see image.

I already try

check connections inside - disconnected battery, clean connections and reconnect .

hard reset, don’t even show anything on screen.

charging for days even it don’t show any signals that are charging I left it there and after few days checked and nothing.

search other similar questions and nothing worked.

If anyone have any idea I really appreciate.

Thank you.

Block Image

Update (11/25/2018)

@jayeff thank you but I can’t even turn it on to the flashing screen.

One additional info when I connect it to the computer I got an error device not recognised.

thank you,

Block Image

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
2 Комментариев

My asus memo made in china model k001 input +5V=2A,10 Wow do I unlock my tabletboot not warking boot is not warking show signature mismacht booting failed unrecoverable bootloader error ( 0x00000008).show this paragraf plz tell me and


And send me soft ware file plz


Добавить комментарий

1 ответ

Выбранное решение

Hi @i2023 ,

Try reflashing the ROM and see if that will work.

Here’s just one link that I found.

Ensure that it is for your exact model as flashing the incorrect firmware can brick the device.

Был ли этот ответ полезен?

Оценка 2

3 Комментариев:

Hi @i2023 ,

Well something is still alive in the tablet because windows recognizes something has been connected.

Just verifying that when you tried the procedure as outlined in the link that nothing happens when you have the micro SD Card with the firmware inserted. Is this correct?

Here's the procedure:

Press BOTH Power_On + Volume_Up and hold together until the logo “No USB connected” show up,

release the buttons and then press BOTH Volume_Down + Volume_Up together. when options appear release the buttons and select the option “SD DOWNLOAD”. (use the vol button to step and the power button to enter)

Wait for flashing process to begin and complete


If this is what you tried and it still didn't do anything, I'm sorry that I can't think of anything else to try.


Thank you Jayeff,

nothing happens in this tablet when doing this. Not even any reaction on the screen.

The only situation when there is anything moving is when I connect charger and the green battery shows charging for few seconds until disappear again "forever"...

Don't know what else to think, maybe this is a hardware problem.

Thank you for your interest in this,


Hi @i2023 ,

It could be a hardware failure.

Normally there is a backup copy of the firmware on non volatile memory (can't be altered by the user) in the tablet which allows you to reset it back to factory default firmware condition, using either the menu options in a working tablet or the combination of buttons to access the area where this software is stored and start the process in case the "working" firmware (which can be altered by the user) which is normally accessed to start the tablet has become corrupted

So it could be if it was a hardware fault (and you don't know where - it could be as simple as one of the buttons not working or as hard as the memory chip has failed) then it won't start with the hardware buttons reset method either.


Добавить комментарий

Добавьте свой ответ

2023 Days будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 4

За последние 7 дней: 7

За последние 30 дней: 23

За всё время: 2,133